aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xorgxrdp-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xorgxrdp-devel/Makefile')
-rw-r--r--x11-drivers/xorgxrdp-devel/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-drivers/xorgxrdp-devel/Makefile b/x11-drivers/xorgxrdp-devel/Makefile
new file mode 100644
index 000000000000..426f56502a05
--- /dev/null
+++ b/x11-drivers/xorgxrdp-devel/Makefile
@@ -0,0 +1,47 @@
+PORTNAME= xorgxrdp
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.19.b20220329
+CATEGORIES= x11-drivers
+PKGNAMESUFFIX= -devel
+DIST_SUBDIR= xrdp
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+
+MAINTAINER= meta@FreeBSD.org
+COMMENT= X.Org driver enabling use through an RDP session with xrdp
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= xauth:x11/xauth
+BUILD_DEPENDS= nasm:devel/nasm
+
+USES= autoreconf libtool:build localbase pkgconfig xorg
+USE_XORG= xorgproto xorg-server
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+
+GH_ACCOUNT= neutrinolabs
+GH_TAGNAME= 0d5cbfe
+GH_TUPLE= neutrinolabs:xrdp:cd1af47:xrdp
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ENV= XRDP_CFLAGS=-I${WRKSRC_xrdp}/common
+CONFLICTS= xorgxrdp
+
+OPTIONS_DEFINE= DEBUG DRI3
+OPTIONS_DEFAULT=
+
+DRI3_DESC= DRI3/Glamor OpenGL Support
+DRI3_CONFIGURE_ENABLE= glamor
+DRI3_LIB_DEPENDS= libepoxy.so:graphics/libepoxy
+DRI3_SUB_FILES= pkg-message
+
+post-patch-DEBUG-on:
+ ${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's|#define LOG_LEVEL [0-9]*|#define LOG_LEVEL 20|'
+
+pre-configure:
+ @cd ${WRKSRC} && ./bootstrap
+
+.include <bsd.port.mk>