aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xorgxrdp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xorgxrdp/Makefile')
-rw-r--r--x11-drivers/xorgxrdp/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/x11-drivers/xorgxrdp/Makefile b/x11-drivers/xorgxrdp/Makefile
index d5a6d88b6b04..902dcf6a854b 100644
--- a/x11-drivers/xorgxrdp/Makefile
+++ b/x11-drivers/xorgxrdp/Makefile
@@ -12,11 +12,12 @@ MAINTAINER= meta@FreeBSD.org
COMMENT= X.Org driver enabling use through an RDP session with xrdp
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= xauth:x11/xauth
BUILD_DEPENDS= nasm:devel/nasm
-USES= autoreconf libtool:build pkgconfig xorg
+USES= autoreconf libtool:build localbase pkgconfig xorg
USE_XORG= xorgproto xorg-server
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -27,8 +28,6 @@ GH_TAGNAME= v0.9.14:xrdp
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-CFLAGS+= -I${LOCALBASE}/include
-LIBS= -L${LOCALBASE}/lib
CONFIGURE_ENV= XRDP_CFLAGS=-I${WRKSRC_xrdp}/common
OPTIONS_DEFINE= DEBUG DRI3
@@ -37,12 +36,7 @@ OPTIONS_DEFAULT=
DRI3_DESC= DRI3/Glamor OpenGL Support
DRI3_CONFIGURE_ENABLE= glamor
DRI3_LIB_DEPENDS= libepoxy.so:graphics/libepoxy
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDRI3}
-SUB_FILES= pkg-message
-.endif
+DRI3_SUB_FILES= pkg-message
post-patch-DEBUG-on:
${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's|#define LOG_LEVEL [0-9]*|#define LOG_LEVEL 20|'
@@ -50,4 +44,4 @@ post-patch-DEBUG-on:
pre-configure:
@cd ${WRKSRC} && ./bootstrap
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>