aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/worker/Makefile8
-rw-r--r--x11-fm/worker/distinfo6
-rw-r--r--x11-fm/worker/files/patch-configure20
3 files changed, 28 insertions, 6 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index cdcd45c2fb19..29f4563cc220 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= worker
-PORTVERSION= 4.5.1
+PORTVERSION= 4.6.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/cms/worker/downloads/
@@ -14,9 +14,11 @@ LICENSE= GPLv2+
RUN_DEPENDS= bash:shells/bash
USES= compiler:c++14-lang localbase pkgconfig python:run \
- shebangfix tar:bzip2 xorg
+ shebangfix ssl tar:bzip2 xorg
GNU_CONFIGURE= yes
-USE_XORG= x11 xinerama
+CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
+USE_XORG= ice sm x11 xinerama
SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor \
diff --git a/x11-fm/worker/distinfo b/x11-fm/worker/distinfo
index b64457317be1..3c36e4cebcdb 100644
--- a/x11-fm/worker/distinfo
+++ b/x11-fm/worker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598384043
-SHA256 (worker-4.5.1.tar.bz2) = 3bb7c8091bf516edab28906453695ac7d0f212a50a924bc029903cb9cc051e40
-SIZE (worker-4.5.1.tar.bz2) = 1608624
+TIMESTAMP = 1606600381
+SHA256 (worker-4.6.0.tar.bz2) = bb21d11991476b69451caa2d47970cb915b5860d30f5d9beb60b1ea10c06e360
+SIZE (worker-4.6.0.tar.bz2) = 1613476
diff --git a/x11-fm/worker/files/patch-configure b/x11-fm/worker/files/patch-configure
new file mode 100644
index 000000000000..c501fa5339de
--- /dev/null
+++ b/x11-fm/worker/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2020-11-28 21:52:13 UTC
++++ configure
+@@ -21598,7 +21598,7 @@ if test -n "$PKG_CONFIG" && \
+ ($PKG_CONFIG --exists --print-errors "openssl") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
++ test $ac_status = 0 -o -n "$OPENSSL_CFLAGS" -o -n "$OPENSSL_LIBS"; }; then
+
+
+ pkg_failed=no
+@@ -25182,6 +25182,8 @@ fi
+
+ if test "$have_openssl_sha256" = "yes"; then
+ echo " OpenSSL SHA256 : yes"
++ echo " $OPENSSL_CFLAGS"
++ echo " $OPENSSL_LIBS"
+ else
+ echo " OpenSSL SHA256 : no"
+ echo " *** install openssl-dev for checksumming support"