aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/agave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/agave/Makefile')
-rw-r--r--x11-fonts/agave/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-fonts/agave/Makefile b/x11-fonts/agave/Makefile
new file mode 100644
index 000000000000..484aa4404cdb
--- /dev/null
+++ b/x11-fonts/agave/Makefile
@@ -0,0 +1,29 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= agave
+PORTVERSION= 37
+DISTVERSIONPREFIX= v
+CATEGORIES= x11-fonts
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= TrueType monospaced font designed for X environments
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+BUILD_DEPENDS= fontforge:print/fontforge \
+ ttfautohint:print/ttfautohint
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= blobject
+NO_ARCH= yes
+
+WRKSRC_SUBDIR= src
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>