aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/charis-compact/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/charis-compact/Makefile')
-rw-r--r--x11-fonts/charis-compact/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-fonts/charis-compact/Makefile b/x11-fonts/charis-compact/Makefile
new file mode 100644
index 000000000000..1b4c889865b1
--- /dev/null
+++ b/x11-fonts/charis-compact/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: CharisSILCompact
+# Date created: October 14 2011
+# Whom: bf <bf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CharisSILCompact
+PORTVERSION= 4.110
+CATEGORIES= x11-fonts
+MASTER_SITES= http://scripts.sil.org/ttw/fonts2go.cgi?family=CharisSIL&pkg=Compact&ver=${PORTVERSION}&filename=/ \
+ LOCAL/bf
+MASTER_SITE_SUBDIR= #prevent bsd.xorg.mk from setting a default subdirectory
+
+MAINTAINER= bf@FreeBSD.org
+COMMENT= Charis SIL TrueType font collection, compact variant
+
+LICENSE= OFL
+LICENSE_NAME= SIL Open Font License (OFL)
+LICENSE_FILE= ${WRKSRC}/OFL.txt
+LICENSE_PERMS= auto-accept
+
+USE_ZIP= yes
+XORG_CAT= font
+
+FONTROOTDIR= ${PREFIX}/lib/X11/fonts
+INSTALLS_TTF= yes
+NO_BUILD= yes
+USE_TGZ= yes #prevent bsd.xorg.mk from setting USE_BZIP
+
+.for type in B BI I R
+PLIST_FILES+= ${FONTROOTDIR:S/${PREFIX}\///}/${FONTDIR}/${PORTNAME}-${type}.ttf
+.endfor
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= FONTLOG.txt OFL-FAQ.txt OFL.txt README.txt feat_set_tuned.xml
+.endif
+
+SUB_LIST= DIR="${FONTROOTDIR}/${FONTDIR}"
+SUB_FILES= pkg-message
+
+do-configure:
+ @${DO_NADA}
+
+do-install:
+ @${MKDIR} ${FONTROOTDIR}/${FONTDIR}
+ @(cd ${WRKSRC} ; ${INSTALL_DATA} *.ttf ${FONTROOTDIR}/${FONTDIR})
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC} ; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>