aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/cyr-rfx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/cyr-rfx/Makefile')
-rw-r--r--x11-fonts/cyr-rfx/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
index bdf91cdf176a..e5eda1711e03 100644
--- a/x11-fonts/cyr-rfx/Makefile
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyr-rfx-${CYR_RFX_ENCODING}
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fonts ukrainian russian
MASTER_SITES= ftp://ftp.ptc.spbu.ru/mirror/ftp.inp.nsk.su/%SUBDIR%/ \
ftp://ftp.inp.nsk.su/%SUBDIR%/
@@ -17,10 +17,11 @@ EXTRACT_SUFX= .bdfs.tgz
MAINTAINER= mi@aldan.algebra.com
COMMENT= Cyrillic X11 bitmap fonts from CYR-RFX project
-BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT} \
- mkfontdir:${X_CLIENTS_PORT}
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-USE_X_PREFIX= yes
+USE_XORG= x11
# See WWW for other available encodings
CYR_RFX_ENCODING?= koi8-o
@@ -30,11 +31,11 @@ NCPUS!= /sbin/sysctl -n hw.ncpu 2> /dev/null || echo 1
MAKE_ARGS+= -j ${NCPUS}
MAKEFILE= ${FILESDIR}/Makefile.bdf2pcf
INST_DIR= "lib/X11/fonts/${PORTNAME}"
-MAKE_ENV+= INST_DIR="${X11BASE}/${INST_DIR}" MKDIR="${MKDIR}"
+MAKE_ENV+= INST_DIR="${LOCALBASE}/${INST_DIR}" MKDIR="${MKDIR}"
PLIST_SUB+= INST_DIR="${INST_DIR}"
post-install:
- @${SED} -e 's,/usr/X11R6,${X11BASE},g' -e \
+ @${SED} -e 's,/usr/X11R6,${LOCALBASE},g' -e \
's,koi8-o,${CYR_RFX_ENCODING},g' < ${PKGMESSAGE}
.include <bsd.port.mk>