aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/font-manager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/font-manager/Makefile')
-rw-r--r--x11-fonts/font-manager/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
new file mode 100644
index 000000000000..7fa58c255476
--- /dev/null
+++ b/x11-fonts/font-manager/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: font-manager
+# Date created: 2011-03-25
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= font-manager
+PORTVERSION= 0.5.7
+CATEGORIES= x11-fonts gnome
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A font management application for the GNOME desktop
+
+LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
+
+USE_BZIP2= yes
+USE_PYTHON= 2.6-2.7
+USE_GNOME= pygtk2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS= REPORTLAB "Enable font-sampler (PDF sample sheet)" off \
+ NLS "Enable Native Language Support" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITH_REPORTLAB)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/reportlab/:${PORTSDIR}/print/py-reportlab2
+.endif
+
+.include <bsd.port.mk>