aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-arc-themes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-arc-themes/Makefile')
-rw-r--r--x11-themes/gtk-arc-themes/Makefile49
1 files changed, 12 insertions, 37 deletions
diff --git a/x11-themes/gtk-arc-themes/Makefile b/x11-themes/gtk-arc-themes/Makefile
index aef8fdc81a01..cd929893fd19 100644
--- a/x11-themes/gtk-arc-themes/Makefile
+++ b/x11-themes/gtk-arc-themes/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gtk-arc-themes
-DISTVERSION= 20201013
+DISTVERSION= 20210127
CATEGORIES= x11-themes
MAINTAINER= Alexander88207@protonmail.com
@@ -11,51 +11,26 @@ COMMENT= Arc-themes for GTK-2.0 and GTK-3.0 based desktop environments
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= inkscape:graphics/inkscape \
- optipng:graphics/optipng \
+BUILD_DEPENDS= coreutils>0:sysutils/coreutils \
+ inkscape:graphics/inkscape \
sassc:textproc/sassc
-RUN_DEPENDS= gtk-murrine-engine>0:x11-themes/gtk-murrine-engine \
- gnome-themes-extra>0:x11-themes/gnome-themes-extra
+RUN_DEPENDS= gtk-murrine-engine>0:x11-themes/gtk-murrine-engine
-USES= autoreconf gmake gnome pkgconfig
+USES= meson gnome
+
+BINARY_ALIAS= install=ginstall \
+ cp=gcp
USE_GITHUB= yes
GH_ACCOUNT= jnsh
GH_PROJECT= arc-theme
-GNU_CONFIGURE= yes
USE_GNOME= gtk20 gtk30
NO_ARCH= yes
-OPTIONS_DEFINE= CINNAMON GNOMESHELL METACITY PLANK UNITY XFCE
-OPTIONS_DEFAULT= GNOMESHELL METACITY PLANK UNITY XFCE
-OPTIONS_SUB= yes
-
-CINNAMON_BROKEN= Current version of Cinnamon in ports is not supported.
-CINNAMON_DESC= Support for Cinnamon desktop environment
-CINNAMON_IMPLIES= METACITY
-CINNAMON_CONFIGURE_ENABLE= cinnamon
-CINNAMON_BUILD_DEPENDS= cinnamon>0:x11/cinnamon
-
-GNOMESHELL_DESC= Support for Gnome Shell
-GNOMESHELL_CONFIGURE_ENABLE= gnome-shell
-GNOMESHELL_BUILD_DEPENDS= gnome-shell:x11/gnome-shell
-
-METACITY_DESC= Support for Metacity window manager
-METACITY_CONFIGURE_ENABLE= metacity
-
-PLANK_DESC= Support for Plank dock
-PLANK_CONFIGURE_ENABLE= plank
-
-UNITY_DESC= Support for Unity desktop environment
-UNITY_CONFIGURE_ENABLE= unity
-
-XFCE_DESC= Support for Xfce desktop environment
-XFCE_CONFIGURE_ENABLE= xfwm
-
-post-patch:
- ${REINPLACE_CMD} -E 's|^(IconTheme=).*|\1Adwaita|; \
- s|^(CursorTheme=).*|\1Adwaita|' \
- ${WRKSRC}/common/index/*/index.theme
+MESON_ARGS= -Dthemes=cinnamon,gnome-shell,gtk2,gtk3,metacity,plank,unity,xfwm \
+ -Dcinnamon_version=4.8 \
+ -Dgnome_shell_version=3.38 \
+ -Dgtk3_version=3.24
.include <bsd.port.mk>