aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/at-spi/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/at-spi/files')
-rw-r--r--x11-toolkits/at-spi/files/patch-cspi::Makefile.in14
-rw-r--r--x11-toolkits/at-spi/files/patch-cspi::bonobo::Makefile.in14
-rw-r--r--x11-toolkits/at-spi/files/patch-docs::reference::cspi::Makefile.in14
-rw-r--r--x11-toolkits/at-spi/files/patch-libspi::Makefile.in14
-rw-r--r--x11-toolkits/at-spi/files/patch-ltmain.sh45
-rw-r--r--x11-toolkits/at-spi/files/patch-util::magnifier.c14
6 files changed, 115 insertions, 0 deletions
diff --git a/x11-toolkits/at-spi/files/patch-cspi::Makefile.in b/x11-toolkits/at-spi/files/patch-cspi::Makefile.in
new file mode 100644
index 000000000000..fc68138f8acb
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-cspi::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- cspi/Makefile.in 2002/04/12 09:56:02 1.1
++++ cspi/Makefile.in 2002/04/12 09:56:16
+@@ -134,7 +134,7 @@
+
+ lib_LTLIBRARIES = libcspi.la
+
+-INCLUDES = -I $(top_srcdir) -I $(top_builddir) $(LIBCSPI_CFLAGS)
++INCLUDES = -I $(top_srcdir) -I $(top_builddir) @X_CFLAGS@ $(LIBCSPI_CFLAGS)
+
+
+ LDFLAGS = $(LIBCSPI_LIBS) @LT_VERSION_INFO@
diff --git a/x11-toolkits/at-spi/files/patch-cspi::bonobo::Makefile.in b/x11-toolkits/at-spi/files/patch-cspi::bonobo::Makefile.in
new file mode 100644
index 000000000000..a5702214f40c
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-cspi::bonobo::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- cspi/bonobo/Makefile.in 2002/04/12 09:55:03 1.1
++++ cspi/bonobo/Makefile.in 2002/04/12 09:55:22
+@@ -129,7 +129,7 @@
+ X_LIBS = @X_LIBS@
+ cxxflags_set = @cxxflags_set@
+
+-INCLUDES = -I $(top_srcdir) -I $(top_builddir) $(LIBCSPI_CFLAGS)
++INCLUDES = -I $(top_srcdir) -I $(top_builddir) @X_CFLAGS@ $(LIBCSPI_CFLAGS)
+
+
+ noinst_LTLIBRARIES = libcspi-bonobo.la
diff --git a/x11-toolkits/at-spi/files/patch-docs::reference::cspi::Makefile.in b/x11-toolkits/at-spi/files/patch-docs::reference::cspi::Makefile.in
new file mode 100644
index 000000000000..5b20d1928ef5
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-docs::reference::cspi::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- docs/reference/cspi/Makefile.in 2002/04/12 10:18:10 1.1
++++ docs/reference/cspi/Makefile.in 2002/04/12 10:18:49
+@@ -146,7 +146,7 @@
+
+ INSTALLDIR = $(prefix)/share/gtk-doc
+
+-HTML_DIR = ${datadir}/gtk-doc/html
++HTML_DIR = ${prefix}/share/doc
+
+ TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
+
diff --git a/x11-toolkits/at-spi/files/patch-libspi::Makefile.in b/x11-toolkits/at-spi/files/patch-libspi::Makefile.in
new file mode 100644
index 000000000000..2cf07a20d6ce
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-libspi::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libspi/Makefile.in 2002/04/12 11:14:12 1.1
++++ libspi/Makefile.in 2002/04/12 11:14:54
+@@ -160,7 +160,7 @@
+ orbittypelibdir = $(libdir)/orbit-2.0
+ orbittypelib_LTLIBRARIES = Accessibility_module.la
+
+-Accessibility_module_la_LDFLAGS = -export-dynamic -module
++Accessibility_module_la_LDFLAGS = -export-dynamic -module -avoid-version
+
+ Accessibility_module_la_SOURCES = Accessibility-imodule.c
+
diff --git a/x11-toolkits/at-spi/files/patch-ltmain.sh b/x11-toolkits/at-spi/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/at-spi/files/patch-util::magnifier.c b/x11-toolkits/at-spi/files/patch-util::magnifier.c
new file mode 100644
index 000000000000..a19760e4297f
--- /dev/null
+++ b/x11-toolkits/at-spi/files/patch-util::magnifier.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- util/magnifier.c 2002/04/12 09:58:25 1.1
++++ util/magnifier.c 2002/04/12 10:07:31
+@@ -11,7 +11,7 @@
+ */
+ #define PARENT_TYPE BONOBO_OBJECT_TYPE
+
+-struct sockaddr_un mag_server = { AF_UNIX , "/tmp/magnifier_socket" };
++struct sockaddr_un mag_server = { 0, AF_UNIX , "/tmp/magnifier_socket" };
+
+ typedef struct {
+ gchar *target_display;