aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ewl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ewl/Makefile')
-rw-r--r--x11-toolkits/ewl/Makefile48
1 files changed, 35 insertions, 13 deletions
diff --git a/x11-toolkits/ewl/Makefile b/x11-toolkits/ewl/Makefile
index 737e4dafb158..89ba1f660298 100644
--- a/x11-toolkits/ewl/Makefile
+++ b/x11-toolkits/ewl/Makefile
@@ -6,32 +6,54 @@
#
PORTNAME= ewl
-PORTVERSION= 0.0.4.007
+PORTVERSION= 20060926
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= x11-toolkits
-MASTER_SITES= http://enlightenment.freedesktop.org/files/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
-MAINTAINER= vanilla@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightened Widget Library
-LIB_DEPENDS= embryo.9:${PORTSDIR}/lang/embryo \
- edb.1:${PORTSDIR}/databases/edb \
- evas.1:${PORTSDIR}/graphics/evas \
- edje.5:${PORTSDIR}/graphics/edje \
- ecore.1:${PORTSDIR}/x11/ecore
-
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig gnometarget
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_EFL= embryo edb evas edje ecore
+WANT_EFL= yes
+USE_LDCONFIG= yes
+
+OPTIONS= EPSILON "Enable Epsilon Support for Ewl_Image" on \
+ EMOTION "Enable Emotion Support for Ewl_Media" on
.include <bsd.port.pre.mk>
+BEFOREPORTMK= yes
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.undef BEFOREPORTMK
.if ${ARCH} == ia64
BROKEN= does not compile on ${ARCH}
.endif
+.if !defined(WITHOUT_EPSILON) || ${HAVE_EFL:Mepsilon}
+USE_EFL+= epsilon
+PLIST_SUB+= EPSILON=""
+.else
+PLIST_SUB+= EPSILON="@comment "
+.endif
+
+.if !defined(WITHOUT_EMOTION) || ${HAVE_EFL:Memotion}
+USE_EFL+= emotion
+PLIST_SUB+= EMOTION=""
+.else
+PLIST_SUB+= EMOTION="@comment "
+.endif
+
+.if exists(${LOCALBASE}/include/Evas_Engine_GL_X11.h)
+PLIST_SUB+= EVAS_GL=""
+.else
+PLIST_SUB+= EVAS_GL="@comment "
+.endif
+
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
.include <bsd.port.post.mk>