aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index b800e842d7dd..63281080b759 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: fltk
-# Version required: 1.0.2
+# Version required: 1.0.7
# Date created: 11 February 1999
# Whom: Dima Sivachenko <dima@Chg.RU>
#
# $FreeBSD$
#
-DISTNAME= fltk-1.0.3-source
-PKGNAME= fltk-1.0.3
+DISTNAME= fltk-1.0.7-source
+PKGNAME= fltk-1.0.7
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.fltk.org/pub/fltk/${VERSION}/ \
ftp://ftp.chg.ru/pub/X11/fltk/${VERSION}/ \
@@ -20,13 +20,13 @@ MAINTAINER= dima@chg.ru
LIB_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3
+VERSION= 1.0.7
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
WRKSRC= ${WRKDIR}/${PKGNAME}
USE_X_PREFIX= yes
MAN1= fluid.1
-VERSION= 1.0.3
.include <bsd.port.pre.mk>
.if (${PORTOBJFORMAT} == "aout")
@@ -39,11 +39,11 @@ post-install:
${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/fltk
- @ ${INSTALL_DATA} ${WRKSRC}/documentation/*.html \
- ${PREFIX}/share/doc/fltk
- @ ${INSTALL_DATA} ${WRKSRC}/documentation/*.gif \
- ${PREFIX}/share/doc/fltk
- @ ${INSTALL_DATA} ${WRKSRC}/documentation/*.jpg \
+ for ext in html gif jpg ; do \
+ ${INSTALL_DATA} ${WRKSRC}/documentation/*.$$ext \
+ ${PREFIX}/share/doc/fltk; \
+ done
+ ${INSTALL_DATA} ${WRKSRC}/documentation/README \
${PREFIX}/share/doc/fltk
.endif