aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/devilspie/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/devilspie/Makefile')
-rw-r--r--x11-wm/devilspie/Makefile36
1 files changed, 15 insertions, 21 deletions
diff --git a/x11-wm/devilspie/Makefile b/x11-wm/devilspie/Makefile
index b492abd714b3..9b46916ed395 100644
--- a/x11-wm/devilspie/Makefile
+++ b/x11-wm/devilspie/Makefile
@@ -5,31 +5,25 @@
# $FreeBSD$
#
-PORTNAME= devilspie
-PORTVERSION= 0.8
-PORTREVISION= 1
-CATEGORIES= x11-wm
-MASTER_SITES= http://www.burtonini.com/computing/
+PORTNAME= devilspie
+PORTVERSION= 0.10
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.burtonini.com/computing/
-MAINTAINER= jylefort@FreeBSD.org
-COMMENT= A window manipulation tool
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A window manipulation tool
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-USE_X_PREFIX= yes
-USE_GNOME= libwnck libxml2
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_X_PREFIX= yes
+USE_GNOME= libwnck libxml2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-MAN1= devilspie.1
-
-post-patch:
- @${FIND} ${WRKSRC}/src -name '*.c' | ${XARGS} ${REINPLACE_CMD} -e \
- 's/G_PARAM_WRITABLE/& | G_PARAM_CONSTRUCT/'
+MAN1= devilspie.1
post-install:
${MKDIR} ${DATADIR}