aboutsummaryrefslogtreecommitdiff
path: root/x11/alacritty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/alacritty/Makefile')
-rw-r--r--x11/alacritty/Makefile204
1 files changed, 99 insertions, 105 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index 7a2c555ef03e..2774c6b044c4 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= alacritty
-PORTVERSION= g20180126
-PORTREVISION= 3
+PORTVERSION= g20180717
CATEGORIES= x11
MAINTAINER= zeising@FreeBSD.org
@@ -16,50 +15,51 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= jwilm
-GH_TAGNAME= b82622e9948d1c90fc628739c7f328816214fb33
+GH_TAGNAME= 7cc9c11
GH_TUPLE= jwilm:rust-fontconfig:be2b94de833ec69cf767186262a5fb8360fa5b45:servofontconfig \
jwilm:libfontconfig:5c1845e1bffa11cf4d3e6fb27f456bf5c814ce1b:servofontconfigsys
PLIST_FILES= bin/alacritty \
- ${DESKTOPDIR:S,^${PREFIX}/,,}/Alacritty.desktop
+ man/man1/alacritty.1.gz \
+ etc/bash_completion.d/alacritty-completions.bash \
+ share/fish/completions/alacritty-completions.fish \
+ share/zsh/site-functions/_alacritty \
+ ${DESKTOPDIR:S,^${PREFIX}/,,}/alacritty.desktop
CARGO_CRATES= aho-corasick-0.6.4 \
android_glue-0.2.3 \
- ansi_term-0.10.2 \
+ ansi_term-0.11.0 \
approx-0.1.1 \
- arraydeque-0.2.3 \
- atty-0.2.6 \
- base64-0.9.0 \
+ arraydeque-0.4.2 \
+ atty-0.2.10 \
+ base64-0.9.2 \
bitflags-0.4.0 \
bitflags-0.7.0 \
bitflags-0.8.2 \
- bitflags-0.9.1 \
- bitflags-1.0.1 \
+ bitflags-1.0.3 \
block-0.1.6 \
- byteorder-1.2.1 \
+ byteorder-1.2.3 \
bytes-0.3.0 \
- cargo_metadata-0.2.3 \
- cc-1.0.4 \
- cfg-if-0.1.2 \
- cgl-0.2.1 \
- cgmath-0.16.0 \
- chrono-0.4.0 \
- clap-2.29.2 \
- clippy-0.0.182 \
- clippy_lints-0.0.182 \
- cmake-0.1.29 \
- cocoa-0.13.0 \
- core-foundation-0.4.6 \
- core-foundation-sys-0.4.6 \
- core-graphics-0.12.4 \
- core-text-8.0.0 \
- dlib-0.4.0 \
+ cc-1.0.17 \
+ cfg-if-0.1.3 \
+ cgl-0.2.2 \
+ cgmath-0.16.1 \
+ clap-2.31.2 \
+ cmake-0.1.31 \
+ cocoa-0.15.0 \
+ core-foundation-0.5.1 \
+ core-foundation-0.6.0 \
+ core-foundation-sys-0.5.1 \
+ core-foundation-sys-0.6.0 \
+ core-graphics-0.13.0 \
+ core-graphics-0.14.0 \
+ core-text-9.2.0 \
+ dlib-0.4.1 \
+ downcast-rs-1.0.3 \
dtoa-0.4.2 \
- dwmapi-sys-0.1.1 \
- either-1.4.0 \
- env_logger-0.5.3 \
+ env_logger-0.5.10 \
errno-0.2.3 \
- euclid-0.16.2 \
+ euclid-0.17.3 \
expat-sys-2.1.5 \
filetime-0.1.15 \
fnv-1.0.6 \
@@ -71,120 +71,103 @@ CARGO_CRATES= aho-corasick-0.6.4 \
fsevent-sys-0.1.6 \
fuchsia-zircon-0.3.3 \
fuchsia-zircon-sys-0.3.3 \
- gdi32-sys-0.1.2 \
- getopts-0.2.17 \
- gl_generator-0.7.0 \
- gl_generator-0.8.0 \
- gleam-0.4.20 \
- glutin-0.12.0 \
- idna-0.1.4 \
- if_chain-0.1.2 \
+ gl_generator-0.9.0 \
+ gleam-0.5.1 \
+ glutin-0.16.0 \
+ humantime-1.1.1 \
inotify-0.3.0 \
- iovec-0.1.1 \
- itertools-0.6.5 \
- itoa-0.3.4 \
+ iovec-0.1.2 \
+ itoa-0.4.1 \
kernel32-sys-0.2.2 \
- khronos_api-2.0.0 \
- lazy_static-1.0.0 \
+ khronos_api-2.2.0 \
+ lazy_static-1.0.1 \
lazycell-0.4.0 \
lazycell-0.6.0 \
- libc-0.2.40 \
- libloading-0.4.3 \
+ libc-0.2.42 \
+ libloading-0.5.0 \
libz-sys-1.0.18 \
- linked-hash-map-0.5.0 \
+ linked-hash-map-0.5.1 \
log-0.3.9 \
- log-0.4.1 \
+ log-0.4.2 \
malloc_buf-0.0.6 \
- matches-0.1.6 \
memchr-2.0.1 \
memmap-0.6.2 \
mio-0.5.1 \
- mio-0.6.12 \
+ mio-0.6.14 \
mio-more-0.1.0 \
miow-0.1.5 \
miow-0.2.1 \
- net2-0.2.31 \
+ net2-0.2.32 \
+ nix-0.11.0 \
nix-0.5.1 \
- nodrop-0.1.12 \
notify-4.0.3 \
- num-0.1.41 \
- num-integer-0.1.35 \
- num-iter-0.1.34 \
- num-traits-0.1.42 \
+ num-traits-0.1.43 \
+ num-traits-0.2.4 \
objc-0.2.2 \
objc-foundation-0.1.1 \
objc_id-0.1.0 \
- odds-0.2.26 \
osmesa-sys-0.1.2 \
owning_ref-0.3.3 \
- parking_lot-0.5.3 \
- parking_lot_core-0.2.10 \
+ parking_lot-0.5.5 \
+ parking_lot_core-0.2.14 \
percent-encoding-1.0.1 \
- pkg-config-0.3.9 \
- pulldown-cmark-0.0.15 \
- quine-mc_cluskey-0.2.4 \
- quote-0.3.15 \
- rand-0.3.20 \
+ pkg-config-0.3.11 \
+ proc-macro2-0.4.6 \
+ quick-error-1.2.2 \
+ quote-0.6.3 \
rand-0.4.2 \
- redox_syscall-0.1.37 \
+ redox_syscall-0.1.40 \
redox_termios-0.1.1 \
- regex-0.2.5 \
- regex-syntax-0.4.2 \
+ regex-1.0.0 \
+ regex-syntax-0.6.1 \
+ remove_dir_all-0.5.1 \
safemem-0.2.0 \
same-file-1.0.2 \
- semver-0.6.0 \
- semver-parser-0.7.0 \
- serde-1.0.27 \
- serde_derive-1.0.27 \
- serde_derive_internals-0.19.0 \
- serde_json-1.0.9 \
- serde_yaml-0.7.3 \
+ serde-1.0.66 \
+ serde_derive-1.0.66 \
+ serde_json-1.0.20 \
+ serde_yaml-0.7.5 \
shared_library-0.1.8 \
- shell32-sys-0.1.2 \
slab-0.1.3 \
slab-0.3.0 \
- smallvec-0.6.0 \
- stable_deref_trait-1.0.0 \
- strsim-0.6.0 \
- syn-0.11.11 \
- synom-0.11.3 \
- tempfile-2.2.0 \
- termcolor-0.3.3 \
+ slab-0.4.0 \
+ smallvec-0.6.1 \
+ smithay-client-toolkit-0.2.3 \
+ stable_deref_trait-1.1.0 \
+ static_assertions-0.2.5 \
+ strsim-0.7.0 \
+ syn-0.14.2 \
+ tempfile-3.0.2 \
+ termcolor-0.3.6 \
termion-1.5.1 \
textwrap-0.9.0 \
thread_local-0.3.5 \
- time-0.1.39 \
- token_store-0.1.2 \
- toml-0.4.5 \
- unicode-bidi-0.3.4 \
- unicode-normalization-0.1.5 \
- unicode-width-0.1.4 \
- unicode-xid-0.0.4 \
+ time-0.1.40 \
+ ucd-util-0.1.1 \
+ unicode-width-0.1.5 \
+ unicode-xid-0.1.0 \
unreachable-1.0.0 \
- url-1.6.0 \
- user32-sys-0.1.3 \
utf8-ranges-1.0.0 \
utf8parse-0.1.0 \
- vcpkg-0.2.2 \
- vec_map-0.8.0 \
+ vcpkg-0.2.3 \
+ vec_map-0.8.1 \
void-1.0.2 \
vte-0.3.2 \
- walkdir-2.0.1 \
- wayland-client-0.12.5 \
- wayland-kbd-0.13.1 \
- wayland-protocols-0.12.5 \
- wayland-scanner-0.12.5 \
- wayland-sys-0.12.5 \
- wayland-window-0.13.2 \
+ walkdir-2.1.4 \
+ wayland-client-0.20.10 \
+ wayland-commons-0.20.10 \
+ wayland-protocols-0.20.10 \
+ wayland-scanner-0.20.10 \
+ wayland-sys-0.20.10 \
winapi-0.2.8 \
- winapi-0.3.4 \
+ winapi-0.3.5 \
winapi-build-0.1.1 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- wincolor-0.1.4 \
- winit-0.10.0 \
+ wincolor-0.1.6 \
+ winit-0.15.1 \
ws2_32-sys-0.2.1 \
- x11-dl-2.17.2 \
+ x11-dl-2.18.0 \
xdg-2.1.0 \
xml-rs-0.7.0 \
yaml-rust-0.4.0
@@ -194,6 +177,17 @@ CARGO_GH_CARGOTOML= ${CARGO_CARGOTOML} \
${WRKSRC_servofontconfig}/Cargo.toml
post-install:
- ${INSTALL_DATA} ${WRKSRC}/Alacritty.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/alacritty
+ ${INSTALL_DATA} ${WRKSRC}/alacritty.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_MAN} ${WRKSRC}/alacritty.man ${STAGEDIR}${MANPREFIX}/man/man1/alacritty.1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKSRC}/alacritty-completions.bash \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/fish/completions
+ ${INSTALL_DATA} ${WRKSRC}/alacritty-completions.fish \
+ ${STAGEDIR}${PREFIX}/share/fish/completions
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/alacritty-completions.zsh \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_alacritty
.include <bsd.port.mk>