aboutsummaryrefslogtreecommitdiff
path: root/x11/dmenu/files/patch-config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dmenu/files/patch-config.mk')
-rw-r--r--x11/dmenu/files/patch-config.mk26
1 files changed, 14 insertions, 12 deletions
diff --git a/x11/dmenu/files/patch-config.mk b/x11/dmenu/files/patch-config.mk
index b4f1c9a1cd99..bfa0293d2b0a 100644
--- a/x11/dmenu/files/patch-config.mk
+++ b/x11/dmenu/files/patch-config.mk
@@ -1,6 +1,6 @@
---- config.mk.orig 2007-10-25 20:26:14.000000000 +0200
-+++ config.mk 2007-10-27 00:36:35.000000000 +0200
-@@ -4,19 +4,19 @@
+--- config.mk.orig 2008-06-18 19:20:41.000000000 +0200
++++ config.mk 2008-06-21 14:57:31.000000000 +0200
+@@ -4,11 +4,11 @@
# Customize below to fit your system
# paths
@@ -14,20 +14,22 @@
+X11INC = $(LOCALBASE)/include
+X11LIB = $(LOCALBASE)/lib
- # includes and libs
- INCS = -I. -I/usr/include -I${X11INC}
- LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+ # Xinerama, comment if you don't want it
+ XINERAMALIBS = -L${X11LIB} -lXinerama
+@@ -19,13 +19,13 @@
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
# flags
--CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
+-CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-LDFLAGS = -s ${LIBS}
-+CFLAGS+= ${INCS} -DVERSION=\"${VERSION}\"
++CPPFLAGS+= -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
++CFLAGS+= ${INCS} ${CPPFLAGS}
+LDFLAGS+= ${LIBS}
- #CFLAGS = -g -std=c99 -pedantic -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
- #LDFLAGS = -g ${LIBS}
-@@ -26,4 +26,4 @@
- #CFLAGS += -xtarget=ultra
+ # Solaris
+ #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = ${LIBS}
# compiler and linker
-CC = cc