aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-input/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ecore-input/Makefile')
-rw-r--r--x11/ecore-input/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11/ecore-input/Makefile b/x11/ecore-input/Makefile
new file mode 100644
index 000000000000..cd05c1fcf026
--- /dev/null
+++ b/x11/ecore-input/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: ecore-input
+# Date created: 16 May 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= input
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Enlightenment core abstraction library (input module)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-input
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-input.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>