aboutsummaryrefslogtreecommitdiff
path: root/x11/foot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/foot/Makefile')
-rw-r--r--x11/foot/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11/foot/Makefile b/x11/foot/Makefile
index bb6a1788e6b3..f9ad96a11496 100644
--- a/x11/foot/Makefile
+++ b/x11/foot/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= foot
-DISTVERSION= 1.6.4
+DISTVERSION= 1.7.0
CATEGORIES= x11
MASTER_SITES= https://codeberg.org/dnkl/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
@@ -25,6 +25,14 @@ USES= compiler:c11 meson pkgconfig xorg
USE_XORG= pixman
WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= NOTIFY XDG
+OPTIONS_DEFAULT=NOTIFY XDG
+
+NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
+
+XDG_DESC= Open files with xdg-open
+XDG_RUN_DEPENDS= xdg-open:devel/xdg-utils
+
.if exists(/usr/bin/tic)
PKGMESSAGE= ${NONEXISTENT}
PLIST_FILES+= share/site-terminfo/f/${PORTNAME} \