aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-panel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-panel/Makefile')
-rw-r--r--x11/gnome-panel/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index f4b9b720b80e..49487cf3f0a7 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/x11/gnome-panel/Makefile,v 1.1 2007/12/02 00:54:55 marcus Exp $
+# $MCom: ports/x11/gnome-panel/Makefile,v 1.177 2008/03/23 06:13:12 marcus Exp $
#
PORTNAME= gnome-panel
-PORTVERSION= 2.20.3
-PORTREVISION?= 0
+PORTVERSION= 2.22.0
+PORTREVISION?= 2
CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,19 +20,24 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
+LIB_DEPENDS= gweather.0:${PORTSDIR}/net/libgweather \
+ polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome
+
USE_GETTEXT= yes
USE_XLIB= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
+USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop librsvg2 \
libwnck gnomemenus gnomedocutils ltverhack referencehack
WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
- --with-kde-docdir=${LOCALBASE}/share/doc
+ --with-kde-docdir=${LOCALBASE}/share/doc \
+ --disable-network-manager \
+ --enable-polkit
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -64,6 +68,8 @@ post-patch:
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
's|"applications.menu"|"gnome-applications.menu"|'
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/applets/clock/gweather-xml.c
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )
.for po in da.po it.po zh_CN.po zh_TW.po
@@ -71,6 +77,11 @@ post-patch:
.endfor
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/share/gnome-panel
+ ${INSTALL_DATA} ${FILESDIR}/iso3166.tab \
+ ${PREFIX}/share/gnome-panel/iso3166.tab
+
.include <bsd.port.post.mk>
.endif