aboutsummaryrefslogtreecommitdiff
path: root/x11/libxklavier/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxklavier/Makefile')
-rw-r--r--x11/libxklavier/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/x11/libxklavier/Makefile b/x11/libxklavier/Makefile
index c66d736635f4..64f69d0c2249 100644
--- a/x11/libxklavier/Makefile
+++ b/x11/libxklavier/Makefile
@@ -3,12 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/libxklavier/Makefile,v 1.32 2007/02/24 21:00:46 mezz Exp $
+# $MCom: ports/x11/libxklavier/Makefile,v 1.35 2007/09/10 15:36:39 mezz Exp $
#
PORTNAME= libxklavier
-PORTVERSION= 3.2
-PORTREVISION= 2
+PORTVERSION= 3.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -25,16 +25,20 @@ USE_GNOME= gnometarget gnomehack libxml2 glib20
USE_LDCONFIG= yes
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --disable-doxygen \
- --with-xkb-base=${X11BASE}/share/X11/xkb \
- --with-xkb-bin-base=${X11BASE}/bin \
- --with-xmodmap-base=${LOCALBASE}/share/gnome/xmodmap \
+ --with-xkb-base=${LOCALBASE}/share/X11/xkb \
+ --with-xkb-bin-base=${LOCALBASE}/bin \
+ --with-xmodmap-base=${LOCALBASE}/share/xmodmap \
--disable-gtk-doc \
--with-html-dir=${GNOME_HTML_DIR}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
PLIST_SUB= VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|== "yes|= "yes|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>