aboutsummaryrefslogtreecommitdiff
path: root/x11/p5-X11-Protocol-Other/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/p5-X11-Protocol-Other/Makefile')
-rw-r--r--x11/p5-X11-Protocol-Other/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/x11/p5-X11-Protocol-Other/Makefile b/x11/p5-X11-Protocol-Other/Makefile
index f739181afd9e..d2bb7c2e5286 100644
--- a/x11/p5-X11-Protocol-Other/Makefile
+++ b/x11/p5-X11-Protocol-Other/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= X11-Protocol-Other
-PORTVERSION= 29
-PORTREVISION= 1
+PORTVERSION= 30
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,8 +16,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-X11-Protocol>=0:x11/p5-X11-Protocol
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
NO_ARCH= yes
+OPTIONS_DEFINE= EXAMPLES
+
+SHEBANG_FILES= examples/*.pl
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>