aboutsummaryrefslogtreecommitdiff
path: root/x11/qterminal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qterminal/Makefile')
-rw-r--r--x11/qterminal/Makefile26
1 files changed, 8 insertions, 18 deletions
diff --git a/x11/qterminal/Makefile b/x11/qterminal/Makefile
index c7e2ed32ae4d..b117ed7e06eb 100644
--- a/x11/qterminal/Makefile
+++ b/x11/qterminal/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= qterminal
-PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTVERSION= 0.8.0
CATEGORIES= x11
+MASTER_SITES= LXQT
-MAINTAINER= bacon4000@gmail.com
+MAINTAINER= jesper@schmitz.computer
COMMENT= Lightweight Qt-based terminal emulator
LICENSE= GPLv2
@@ -15,21 +15,11 @@ LIB_DEPENDS= libqtermwidget5.so:x11-toolkits/qtermwidget
RUN_DEPENDS= liberation-fonts-ttf>=2.00:x11-fonts/liberation-fonts-ttf \
qterminal-l10n>0:x11/qterminal-l10n
-USES= cmake:outsource compiler:c++11-lang localbase:ldflags \
- lxqt pkgconfig tar:xz
-USE_QT5= buildtools_build core gui qmake_build widgets x11extras
+USES= cmake:outsource compiler:c++11-lang gettext-runtime \
+ localbase:ldflags lxqt pkgconfig tar:xz
+USE_QT5= buildtools_build core gui qmake_build dbus linguisttools \
+ widgets x11extras
USE_XORG= x11
USE_LXQT= buildtools lxqt
-CMAKE_ARGS+= -DUSE_SYSTEM_QXT:BOOL=OFF
-
-USE_GITHUB= yes
-GH_ACCOUNT= lxde
-
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD
-LDFLAGS+= -lulog
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>