aboutsummaryrefslogtreecommitdiff
path: root/x11/terminator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/terminator/Makefile')
-rw-r--r--x11/terminator/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 7598dcc3bcdb..717c1d1bd02c 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: terminator
-# Date created: 2008-03-14
-# Whom: Thomas Hurst <tom@hur.st>
-#
+# Created by: Thomas Hurst <tom@hur.st>
# $FreeBSD$
-#
PORTNAME= terminator
PORTVERSION= 0.96
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 python
MASTER_SITES= http://launchpadlibrarian.net/80778747/ \
http://hur.st/mirror/terminator/
@@ -17,6 +13,10 @@ COMMENT= Multiple GNOME terminals in one window
LICENSE= GPLv2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0:${PORTSDIR}/devel/py-notify \
+ ${PYTHON_SITELIBDIR}/keybinder/_keybinder.so:${PORTSDIR}/x11/keybinder \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0:${PORTSDIR}/x11-toolkits/py-vte
+
OPTIONS_DEFINE= NLS GCONF
GCONF_DESC= Use GNOME Terminal settings
OPTIONS_DEFAULT= NLS GCONF
@@ -40,7 +40,6 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= pygnome2
.endif