aboutsummaryrefslogtreecommitdiff
path: root/x11/thingylaunch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/thingylaunch/Makefile')
-rw-r--r--x11/thingylaunch/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11/thingylaunch/Makefile b/x11/thingylaunch/Makefile
index 4933c9fb65ac..b874428ed409 100644
--- a/x11/thingylaunch/Makefile
+++ b/x11/thingylaunch/Makefile
@@ -1,20 +1,23 @@
PORTNAME= thingylaunch
-PORTVERSION= 3.0.1
+DISTVERSION= 3.0.2
CATEGORIES= x11
-MASTER_SITES= https://code.ptrcrt.ch/${PORTNAME}/tarball/${PORTVERSION}/
+MASTER_SITES= https://code.ptrcrt.ch/${PORTNAME}/tarball/${DISTVERSION}/
MAINTAINER= gahr@FreeBSD.org
COMMENT= Lightweight launcher for X
WWW= https://code.ptrcrt.ch/${PORTNAME}
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= compiler:c++11-lib pkgconfig xorg
USE_XORG= xorgproto xcb
LIB_DEPENDS+= libxcb-icccm.so:x11/xcb-util-wm \
libxcb-keysyms.so:x11/xcb-util-keysyms
-USE_CXXSTD= c++11
PLIST_FILES= bin/${PORTNAME}
+post-patch:
+ ${REINPLACE_CMD} '/^CXXFLAGS/s|-O3||' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>