aboutsummaryrefslogtreecommitdiff
path: root/x11/x3270/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/x3270/Makefile')
-rw-r--r--x11/x3270/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 244c262d42c9..1f46e14ce135 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -26,6 +26,7 @@ RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
WRKSRC= ${WRKDIR}/x3270-3.1.1
MAN1= x3270.1 x3270if.1 x3270-script.1 ibm_hosts.1
MANCOMPRESSED= yes
+USE_REINPLACE= yes
pre-install:
.if !exists(${X11BASE}/lib/X11/fonts/local)
@@ -36,4 +37,14 @@ pre-install:
@${ECHO} "*********************************************************"
.endif
+#
+# This patch is to make sure that mkversion.sh can be ran on FreeBSD 4-STABLE
+# which will get $(CLIENTENVSETUP) in its CC macro.
+#
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's,sh \./mkversion\.sh $$(CC),$$(CLIENTENVSETUP) sh ./mkversion.sh %%CC%%,' \
+ -e 's,%%CC%%,${CC},' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.post.mk>