aboutsummaryrefslogtreecommitdiff
path: root/x11/xbanish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xbanish/Makefile')
-rw-r--r--x11/xbanish/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11/xbanish/Makefile b/x11/xbanish/Makefile
new file mode 100644
index 000000000000..7f55839dd309
--- /dev/null
+++ b/x11/xbanish/Makefile
@@ -0,0 +1,24 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= xbanish
+PORTVERSION= 1.4
+DISTVERSIONPREFIX= v
+CATEGORIES= x11
+
+MAINTAINER= t@tobik.me
+COMMENT= Banish the mouse cursor when typing
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= jcs
+
+USE_XORG= x11 xfixes xi xt
+
+MAKE_ARGS= X11BASE="${PREFIX}"
+
+PLIST_FILES= bin/xbanish \
+ man/man1/xbanish.1.gz
+
+.include <bsd.port.mk>