aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-terminal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-terminal/Makefile')
-rw-r--r--x11/xfce4-terminal/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index 0a2b576cccc1..511225a99cda 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -1,5 +1,5 @@
PORTNAME= xfce4-terminal
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.5
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
@@ -11,22 +11,29 @@ WWW= https://docs.xfce.org/apps/xfce4-terminal/start
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/catalog.xml:textproc/docbook-xml \
+ ${LOCALBASE}/share/xsl/docbook/html/refentry.xsl:textproc/docbook-xsl \
+ xsltproc:textproc/libxslt
LIB_DEPENDS= libpcre2-8.so:devel/pcre2
-USES= compiler:c11 gettext-tools gmake gnome pkgconfig tar:bzip2 xfce \
+USES= compiler:c11 gettext-tools gnome meson pkgconfig tar:xz xfce \
xorg
USE_GNOME= cairo gdkpixbuf glib20 gtk30 vte3
USE_XFCE= libmenu xfconf
USE_XORG= ice sm x11
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-utempter
-INSTALL_TARGET= install-strip
+MESON_ARGS= -Dlibutempter=enabled
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= NLS WAYLAND
+OPTIONS_DEFAULT= WAYLAND
+OPTIONS_SUB= yes
-NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
+WAYLAND_LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+WAYLAND_MESON_ENABLED= gtk-layer-shell wayland
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e "/^subdir('po')/d" ${WRKSRC}/meson.build
.include <bsd.port.mk>