aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/brisk-menu/files/patch-src_meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11/brisk-menu/files/patch-src_meson.build b/x11/brisk-menu/files/patch-src_meson.build
new file mode 100644
index 000000000000..5b311b77f43b
--- /dev/null
+++ b/x11/brisk-menu/files/patch-src_meson.build
@@ -0,0 +1,20 @@
+Attempt to unbreak parallel build
+
+--- src/meson.build.orig 2021-04-05 04:30:02 UTC
++++ src/meson.build
+@@ -13,6 +13,7 @@ libresources = static_library(
+
+ link_libresources = declare_dependency(
+ link_with: libresources,
++ sources: brisk_resources,
+ include_directories: [
+ data_include,
+ ],
+@@ -38,6 +39,7 @@ libsession_stub = static_library(
+ # Allow linking to the stub
+ link_libsession_stub = declare_dependency(
+ link_with: libsession_stub,
++ sources: [libsaver_glue, libsession_glue],
+ dependencies: [
+ dep_gio_unix,
+ ],