aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/printext/Makefile29
-rw-r--r--x11/printext/distinfo2
-rw-r--r--x11/printext/pkg-descr3
-rw-r--r--x11/printext/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index bc927c613c6b..fbddafd518c1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -127,6 +127,7 @@
SUBDIR += peeper
SUBDIR += portoseguro
SUBDIR += powershell
+ SUBDIR += printext
SUBDIR += props
SUBDIR += qrash
SUBDIR += randrext
diff --git a/x11/printext/Makefile b/x11/printext/Makefile
new file mode 100644
index 000000000000..22b8a6d1eb03
--- /dev/null
+++ b/x11/printext/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: PrintExt
+# Date Created: 4 May 2004
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PrintExt
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~xorg/release/
+DISTNAME= X11R6.7.0-src1
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Header files for the X Print Extension
+
+CONFLICTS= XFree86-libraries-*
+
+PREFIX?= ${X11BASE}
+DIST_SUBDIR= xorg
+WRKSRC= ${WRKDIR}/xc/include/extensions
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - xc/include/extensions
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL} ${WRKSRC}/Print.h ${PREFIX}/include/X11/extensions
+ ${INSTALL} ${WRKSRC}/Printstr.h ${PREFIX}/include/X11/extensions
+
+.include <bsd.port.mk>
diff --git a/x11/printext/distinfo b/x11/printext/distinfo
new file mode 100644
index 000000000000..3b6121dc89e0
--- /dev/null
+++ b/x11/printext/distinfo
@@ -0,0 +1,2 @@
+MD5 (xorg/X11R6.7.0-src1.tar.gz) = 22465263bae7a2e9f5ad77e172cf1ab5
+SIZE (xorg/X11R6.7.0-src1.tar.gz) = 30039655
diff --git a/x11/printext/pkg-descr b/x11/printext/pkg-descr
new file mode 100644
index 000000000000..918aad4e5500
--- /dev/null
+++ b/x11/printext/pkg-descr
@@ -0,0 +1,3 @@
+This package contains header files for the X Print extension.
+
+WWW: http://www.freedesktop.org/Software/xorg
diff --git a/x11/printext/pkg-plist b/x11/printext/pkg-plist
new file mode 100644
index 000000000000..8b1ac7295114
--- /dev/null
+++ b/x11/printext/pkg-plist
@@ -0,0 +1,2 @@
+include/X11/extensions/Print.h
+include/X11/extensions/Printstr.h