aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 22:11:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 22:11:22 +0000
commit4ecea33a988c00caa98cacf934e61e361d94e8af (patch)
tree7089d85dfa0daa5568799f671cfb9924f1012710 /configure.in
parente0ae66db632ac7c7773c8b85754bfc135f5bdbd5 (diff)
downloadsrc-4ecea33a988c00caa98cacf934e61e361d94e8af.tar.gz
src-4ecea33a988c00caa98cacf934e61e361d94e8af.zip
Notes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 33 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 477c187a3852..0cd7a1996ded 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with 'autoconf' to produce a 'configure' script
-dnl $Id: configure.in,v 1.15 2014/01/01 14:07:34 tom Exp $
+dnl $Id: configure.in,v 1.18 2014/04/06 19:11:51 tom Exp $
AC_PREREQ(2.52.20011201)
-AC_REVISION($Revision: 1.15 $)
+AC_REVISION($Revision: 1.18 $)
AC_INIT(main.c)
AC_CONFIG_HEADER(config.h:config_h.in)
@@ -12,12 +12,43 @@ CF_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_INSTALL
CF_MAKE_TAGS
+CF_PROG_AWK
CF_PROG_LINT
CF_XOPEN_SOURCE
AC_CHECK_HEADERS(fcntl.h)
CF_MKSTEMP
+AC_MSG_CHECKING(for maximum table size)
+AC_ARG_WITH([max-table-size],
+ [AC_HELP_STRING([--with-max-table-size=N],
+ [set the maximum table size = N (no default)])])
+if test -n "$with_max_table_size"
+then
+ AC_MSG_RESULT($with_max_table_size)
+ check=`expr "$with_max_table_size" + 0`
+ if test "x$check" != "x$with_max_table_size"
+ then
+ AC_MSG_ERROR([invalid value for --with-max-table-size: $with_max_table_size])
+ fi
+ AC_DEFINE_UNQUOTED(MAXTABLE,$with_max_table_size,[Define to maximum table size (default: 32500)])
+else
+ AC_MSG_RESULT(default)
+fi
+
+AC_MSG_CHECKING(if backtracking extension is wanted)
+AC_ARG_ENABLE([btyacc],
+ [AC_HELP_STRING([--enable-btyacc],
+ [turn on support for the btyacc backtracking extension (default: no)])])
+AC_MSG_RESULT($enable_btyacc)
+if test "$enable_btyacc" = "yes"; then
+ AC_DEFINE(YYBTYACC,1,[Define to 1 to enable backtracking extension])
+ SKELETON=btyaccpar
+else
+ SKELETON=yaccpar
+fi
+AC_SUBST(SKELETON)
+
CF_WITH_WARNINGS(Wwrite-strings)
CF_DISABLE_ECHO
CF_DISABLE_LEAKS