aboutsummaryrefslogtreecommitdiff
path: root/include/clang/Lex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/clang/Lex/CMakeLists.txt')
-rw-r--r--include/clang/Lex/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/clang/Lex/CMakeLists.txt b/include/clang/Lex/CMakeLists.txt
new file mode 100644
index 000000000000..b823e83f906b
--- /dev/null
+++ b/include/clang/Lex/CMakeLists.txt
@@ -0,0 +1,6 @@
+set(LLVM_TARGET_DEFINITIONS ../Basic/Attr.td)
+tablegen(AttrSpellings.inc
+ -gen-clang-attr-spelling-list
+ -I ${CMAKE_CURRENT_SOURCE_DIR}/../../)
+add_custom_target(ClangAttrSpellings
+ DEPENDS AttrSpellings.inc)