aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-06-16 16:11:08 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-06-16 16:11:08 +0000
commit470d13c7ed1bb6b01c1600182343aa64a3abc050 (patch)
treeaddde23980c745539537840f5e7f5e05f0324f6c
parent3272e882b8a7c78756680d3b45fd093e15e9316f (diff)
downloadports-470d13c7ed1bb6b01c1600182343aa64a3abc050.tar.gz
ports-470d13c7ed1bb6b01c1600182343aa64a3abc050.zip
Notes
-rw-r--r--net/v6eval/Makefile167
-rw-r--r--net/v6eval/files/patch-Makefile36
-rw-r--r--net/v6eval/files/patch-bin-remotes-Makefile19
-rw-r--r--net/v6eval/files/patch-bin-remotes-manual-Makefile23
-rw-r--r--net/v6eval/files/patch-bin-remotes-unknown-Makefile23
-rw-r--r--net/v6eval/files/patch-etc-Makefile22
-rw-r--r--net/v6eval/files/patch-include-Makefile27
-rw-r--r--net/v6eval/files/patch-sample-Makefile11
-rw-r--r--net/v6eval/files/patch-script-pmod-V6evalCommon-V6evalCommon.pm11
-rw-r--r--net/v6eval/pkg-plist119
10 files changed, 455 insertions, 3 deletions
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 771bf7c04f24..6d979e666a21 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -3,7 +3,7 @@
PORTNAME= v6eval
PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tahi.org/release/v6eval/
@@ -14,11 +14,165 @@ COMMENT= IPv6 Conformance Test Platform
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
+RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
USE_PERL5= yes
USE_OPENSSL= yes
+USES= shebangfix
+SHEBANG_FILES= \
+ bin/autorun/autorun.pl \
+ bin/indexgen/indexgen.pl \
+ bin/pktbuf/pktbuf.pl \
+ bin/pktctl/pktctl.pl \
+ bin/pktlint/pktlint.pl \
+ bin/pktrecv/pktrecv.pl \
+ bin/pktsend/pktsend.pl \
+ bin/remotes/manual/cleardefr.rmt \
+ bin/remotes/manual/clearmtu.rmt \
+ bin/remotes/manual/clearnc.rmt \
+ bin/remotes/manual/clearprefix.rmt \
+ bin/remotes/manual/clearroute.rmt \
+ bin/remotes/manual/dhcp6c.rmt \
+ bin/remotes/manual/dhcp6r.rmt \
+ bin/remotes/manual/dhcp6s.rmt \
+ bin/remotes/manual/igmpv3.rmt \
+ bin/remotes/manual/igmpv3config.rmt \
+ bin/remotes/manual/ikeClearAll.rmt \
+ bin/remotes/manual/ikeConfig.rmt \
+ bin/remotes/manual/ikeDump.rmt \
+ bin/remotes/manual/ikeEnable.rmt \
+ bin/remotes/manual/ikeInitiate.rmt \
+ bin/remotes/manual/ikeResetSA.rmt \
+ bin/remotes/manual/ikeSetSA.rmt \
+ bin/remotes/manual/ikeStart.rmt \
+ bin/remotes/manual/ikeStop.rmt \
+ bin/remotes/manual/ikeTunnel.rmt \
+ bin/remotes/manual/ipsecClearAll.rmt \
+ bin/remotes/manual/ipsecEnable.rmt \
+ bin/remotes/manual/ipsecResetSPD.rmt \
+ bin/remotes/manual/ipsecSetSAD.rmt \
+ bin/remotes/manual/ipsecSetSPD.rmt \
+ bin/remotes/manual/loginout.rmt \
+ bin/remotes/manual/manualaddrconf.rmt \
+ bin/remotes/manual/mip6EnableCN.rmt \
+ bin/remotes/manual/mip6EnableHA.rmt \
+ bin/remotes/manual/mip6EnableMN.rmt \
+ bin/remotes/manual/mldv2.rmt \
+ bin/remotes/manual/mldv2DisableHUT.rmt \
+ bin/remotes/manual/mldv2DisableRUT.rmt \
+ bin/remotes/manual/mldv2EnableHUT.rmt \
+ bin/remotes/manual/mldv2EnableRUT.rmt \
+ bin/remotes/manual/mldv2ListenerAPI.rmt \
+ bin/remotes/manual/mldv2SetHUT.rmt \
+ bin/remotes/manual/mldv2SetRUT.rmt \
+ bin/remotes/manual/mldv2config.rmt \
+ bin/remotes/manual/mtuconfig.rmt \
+ bin/remotes/manual/multicastConfig.rmt \
+ bin/remotes/manual/natpt.rmt \
+ bin/remotes/manual/pim6dd.rmt \
+ bin/remotes/manual/ping6.rmt \
+ bin/remotes/manual/racontrol.rmt \
+ bin/remotes/manual/reboot.rmt \
+ bin/remotes/manual/reboot_async.rmt \
+ bin/remotes/manual/ripng_start.rmt \
+ bin/remotes/manual/ripng_stop.rmt \
+ bin/remotes/manual/route.rmt \
+ bin/remotes/manual/rtadvd.rmt \
+ bin/remotes/manual/setDNS.rmt \
+ bin/remotes/manual/showAddr.rmt \
+ bin/remotes/manual/sysctl.rmt \
+ bin/remotes/manual/tcp6.rmt \
+ bin/remotes/manual/tunnel.rmt \
+ bin/remotes/manual/useTempAddr.rmt \
+ bin/remotes/unknown/cleardefr.rmt \
+ bin/remotes/unknown/clearmtu.rmt \
+ bin/remotes/unknown/clearnc.rmt \
+ bin/remotes/unknown/clearprefix.rmt \
+ bin/remotes/unknown/clearroute.rmt \
+ bin/remotes/unknown/dhcp6c.rmt \
+ bin/remotes/unknown/dhcp6r.rmt \
+ bin/remotes/unknown/dhcp6s.rmt \
+ bin/remotes/unknown/igmpv3.rmt \
+ bin/remotes/unknown/igmpv3config.rmt \
+ bin/remotes/unknown/ikeClearAll.rmt \
+ bin/remotes/unknown/ikeConfig.rmt \
+ bin/remotes/unknown/ikeDump.rmt \
+ bin/remotes/unknown/ikeEnable.rmt \
+ bin/remotes/unknown/ikeInitiate.rmt \
+ bin/remotes/unknown/ikeResetSA.rmt \
+ bin/remotes/unknown/ikeSetSA.rmt \
+ bin/remotes/unknown/ikeStart.rmt \
+ bin/remotes/unknown/ikeStop.rmt \
+ bin/remotes/unknown/ikeTunnel.rmt \
+ bin/remotes/unknown/ipsecClearAll.rmt \
+ bin/remotes/unknown/ipsecEnable.rmt \
+ bin/remotes/unknown/ipsecResetSPD.rmt \
+ bin/remotes/unknown/ipsecSetSAD.rmt \
+ bin/remotes/unknown/ipsecSetSPD.rmt \
+ bin/remotes/unknown/loginout.rmt \
+ bin/remotes/unknown/manualaddrconf.rmt \
+ bin/remotes/unknown/mip6EnableCN.rmt \
+ bin/remotes/unknown/mip6EnableHA.rmt \
+ bin/remotes/unknown/mip6EnableMN.rmt \
+ bin/remotes/unknown/mldv2.rmt \
+ bin/remotes/unknown/mldv2config.rmt \
+ bin/remotes/unknown/mtuconfig.rmt \
+ bin/remotes/unknown/multicastConfig.rmt \
+ bin/remotes/unknown/natpt.rmt \
+ bin/remotes/unknown/pim6dd.rmt \
+ bin/remotes/unknown/ping6.rmt \
+ bin/remotes/unknown/racontrol.rmt \
+ bin/remotes/unknown/reboot.rmt \
+ bin/remotes/unknown/ripng_start.rmt \
+ bin/remotes/unknown/ripng_stop.rmt \
+ bin/remotes/unknown/reboot_async.rmt \
+ bin/remotes/unknown/route.rmt \
+ bin/remotes/unknown/rtadvd.rmt \
+ bin/remotes/unknown/setDNS.rmt \
+ bin/remotes/unknown/showAddr.rmt \
+ bin/remotes/unknown/sysctl.rmt \
+ bin/remotes/unknown/tcp6.rmt \
+ bin/remotes/unknown/tunnel.rmt \
+ bin/remotes/unknown/useTempAddr.rmt \
+ sample/64tunnel_ll_ping/ping.seq \
+ sample/HBHoptAfterDstOpt/HBHoptAfterDstOpt.seq \
+ sample/jumbo/jumbo.seq \
+ sample/mld-general/mld-general.seq \
+ sample/na_w_mtu/na_w_mtu.seq \
+ sample/ping/ping.seq \
+ sample/ping4/ping4.seq \
+ sample/ping_frag/ping_frag.seq \
+ sample/ping_from_many_host/ping.seq \
+ sample/ping_glosite/ping_glosite.seq \
+ sample/ping_w_ah/ping.seq \
+ sample/ping_w_ahesp/ping.seq \
+ sample/ping_w_esp/ping.seq \
+ sample/ping_w_espicv/ping.seq \
+ sample/ping_w_espicvespicv/ping.seq \
+ sample/portunreach/portunreach.seq \
+ sample/redirect/redirect.seq \
+ sample/timeexceeded/timeexceeded.seq \
+ sample/udpecho/udpecho.seq \
+ sample/unknownnext/unknownnext.seq \
+ sample_stddef/SendRecv/Recv.seq \
+ sample_stddef/SendRecv/Send.seq \
+ sample_stddef/aes-ctr/aes-ctr.seq \
+ sample_stddef/igmp/igmpv3_test.seq \
+ sample_stddef/mldv2/mldv2_test.seq \
+ sample_stddef/ping_frag/ping_frag.seq \
+ sample_stddef/ping_glosite/ping_glosite.seq \
+ sample_stddef/snmp/snmp.seq \
+ sample_stddef/tcp_handshake/tcp_handshake.seq \
+ script/pmod/V6evalRemote/sample/reboot.rmt \
+ script/pmod/V6evalRemote/sample/ls.rmt \
+ script/pmod/V6evalRemote/sample/reboot_async.rmt \
+ script/pmod/V6evalRemote/V6evalRemote.pm \
+ script/pmod/V6evalTool/V6evalTool.pm
MAKE_JOBS_SAFE= yes
+MAKE_ENV= PREFIX="${PREFIX}" \
+ BSD_INSTALL_DATA="${BSD_INSTALL_DATA}" \
+ BSD_INSTALL_SCRIPT="${BSD_INSTALL_SCRIPT}"
SUB_FILES= pkg-message
NO_MANCOMPRESS= yes
@@ -27,7 +181,16 @@ MAN3PREFIX= ${LOCALBASE}/lib/perl5/${PERL_VER}
MAN1= pktctl.1.gz pktsend.1.gz
MAN3= V6evalRemote.3 V6evalTool.3
+post-patch:
+ ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/script/pmod/V6evalCommon/V6evalCommon.pm
+
post-install:
+ ${FIND} ${WRKSRC}/sample ${WRKSRC}/sample_stddef \
+ -name "*.orig" -a -exec ${RM} -f "{}" \;
+ cd ${WRKSRC} && ${COPYTREE_SHARE} sample ${PREFIX}/v6eval
+ cd ${WRKSRC} && ${COPYTREE_SHARE} sample_stddef ${PREFIX}/v6eval
+ cd ${PREFIX}/v6eval && ${CHMOD} +x ${SHEBANG_FILES:Msample*}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/v6eval/files/patch-Makefile b/net/v6eval/files/patch-Makefile
new file mode 100644
index 000000000000..bfaec94c1f6f
--- /dev/null
+++ b/net/v6eval/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig 2005-05-25 11:46:16.000000000 +0900
++++ Makefile 2013-06-17 01:07:40.000000000 +0900
+@@ -1,10 +1,12 @@
+ SUBDIR=lib bin etc script include
+-PREFIX= /usr/local/v6eval
++PREFIX?= /usr/local
+ DOCFILES=00README INSTALL CHANGELOG \
+- 00README.v6eval INSTALL.v6eval CHANGELOG.v6eval \
+- COPYRIGHT
++ 00README.v6eval INSTALL.v6eval CHANGELOG.v6eval INSTALL.dummies
+
+-DIRS= $(PREFIX) $(PREFIX)/bin $(PREFIX)/man $(PREFIX)/doc
++DIRS= $(PREFIX)/v6eval \
++ $(PREFIX)/v6eval/bin \
++ $(PREFIX)/v6eval/man \
++ $(PREFIX)/v6eval/doc
+ #SECTIONS= 1 2 3 4 5 6 7 8 9 n
+ SECTIONS= 1
+ .MAIN: depend all
+@@ -13,12 +15,12 @@
+ [ -d $$i ] || mkdir $$i; \
+ done
+ # for i in $(SECTIONS); do \
+-# [ -d $(PREFIX)/man/man$$i ] || mkdir $(PREFIX)/man/man$$i; \
+-# [ -d $(PREFIX)/man/cat$$i ] || mkdir $(PREFIX)/man/cat$$i; \
++# [ -d $(PREFIX)/v6eval/man/man$$i ] || mkdir $(PREFIX)/v6eval/man/man$$i; \
++# [ -d $(PREFIX)/v6eval/man/cat$$i ] || mkdir $(PREFIX)/v6eval/man/cat$$i; \
+ # done
+ for i in $(SECTIONS); do \
+- [ -d $(PREFIX)/man/man$$i ] || mkdir $(PREFIX)/man/man$$i; \
++ [ -d $(PREFIX)/v6eval/man/man$$i ] || mkdir $(PREFIX)/v6eval/man/man$$i; \
+ done
+- install -c -o bin -g bin -m 444 $(DOCFILES) $(PREFIX)/doc
++ ${BSD_INSTALL_DATA} $(DOCFILES) $(PREFIX)/v6eval/doc
+
+ .include <bsd.subdir.mk>
diff --git a/net/v6eval/files/patch-bin-remotes-Makefile b/net/v6eval/files/patch-bin-remotes-Makefile
new file mode 100644
index 000000000000..06aa2480ad93
--- /dev/null
+++ b/net/v6eval/files/patch-bin-remotes-Makefile
@@ -0,0 +1,19 @@
+--- bin/remotes/Makefile.orig 2013-06-17 00:08:29.000000000 +0900
++++ bin/remotes/Makefile 2013-06-17 00:17:24.000000000 +0900
+@@ -46,13 +46,13 @@
+ SUBDIR= unknown \
+ manual
+
+-PREFIX=/usr/local/v6eval
++PREFIX?=/usr/local
+ DOCFILES=00README
+
+ depend:
+
+ afterinstall:
+- install -d -o bin -g bin -m 755 $(PREFIX)/bin
+- install -c -o bin -g bin -m 444 $(DOCFILES) $(PREFIX)/bin/
++ install -d -m 555 $(PREFIX)/v6eval/bin
++ ${BSD_INSTALL_DATA} $(DOCFILES) $(PREFIX)/v6eval/bin/
+
+ .include <bsd.subdir.mk>
diff --git a/net/v6eval/files/patch-bin-remotes-manual-Makefile b/net/v6eval/files/patch-bin-remotes-manual-Makefile
new file mode 100644
index 000000000000..1454b0a858ce
--- /dev/null
+++ b/net/v6eval/files/patch-bin-remotes-manual-Makefile
@@ -0,0 +1,23 @@
+--- bin/remotes/manual/Makefile.orig 2009-11-25 16:50:24.000000000 +0900
++++ bin/remotes/manual/Makefile 2013-06-17 00:39:02.000000000 +0900
+@@ -41,8 +41,8 @@
+ # THE POSSIBILITY OF SUCH DAMAGE.
+ #
+
+-PREFIX=/usr/local/v6eval
+-RMTDIR=$(PREFIX)/bin/manual
++PREFIX?=/usr/local
++RMTDIR=$(PREFIX)/v6eval/bin/manual
+ REMOTES= cleardefr.rmt \
+ clearmtu.rmt \
+ clearnc.rmt \
+@@ -106,6 +106,6 @@
+ clean:
+
+ install:
+- install -d -o bin -g bin -m 755 $(PREFIX)/bin
+- install -d -o bin -g bin -m 755 $(RMTDIR)
+- install -c -o bin -g bin -m 555 $(REMOTES) $(RMTDIR)
++ install -d -m 555 $(PREFIX)/v6eval/bin
++ install -d -m 555 $(RMTDIR)
++ ${BSD_INSTALL_SCRIPT} $(REMOTES) $(RMTDIR)
diff --git a/net/v6eval/files/patch-bin-remotes-unknown-Makefile b/net/v6eval/files/patch-bin-remotes-unknown-Makefile
new file mode 100644
index 000000000000..180a6bd8988c
--- /dev/null
+++ b/net/v6eval/files/patch-bin-remotes-unknown-Makefile
@@ -0,0 +1,23 @@
+--- bin/remotes/unknown/Makefile.orig 2005-11-10 12:54:12.000000000 +0900
++++ bin/remotes/unknown/Makefile 2013-06-17 00:39:47.000000000 +0900
+@@ -43,8 +43,8 @@
+
+ PRODUCT=unknown
+
+-PREFIX=/usr/local/v6eval
+-RMTDIR=$(PREFIX)/bin/$(PRODUCT)
++PREFIX?=/usr/local
++RMTDIR=$(PREFIX)/v6eval/bin/$(PRODUCT)
+ REMOTES= cleardefr.rmt \
+ clearmtu.rmt \
+ clearnc.rmt \
+@@ -101,6 +101,6 @@
+ clean:
+
+ install:
+- install -d -o bin -g bin -m 755 $(PREFIX)/bin
+- install -d -o bin -g bin -m 755 $(RMTDIR)
+- install -c -o bin -g bin -m 555 $(REMOTES) $(RMTDIR)
++ install -d -m 555 $(PREFIX)/v6eval/bin
++ install -d -m 555 $(RMTDIR)
++ ${BSD_INSTALL_SCRIPT} $(REMOTES) $(RMTDIR)
diff --git a/net/v6eval/files/patch-etc-Makefile b/net/v6eval/files/patch-etc-Makefile
new file mode 100644
index 000000000000..710e6dae8262
--- /dev/null
+++ b/net/v6eval/files/patch-etc-Makefile
@@ -0,0 +1,22 @@
+--- etc/Makefile.orig 2013-06-17 00:07:30.000000000 +0900
++++ etc/Makefile 2013-06-17 00:18:09.000000000 +0900
+@@ -43,15 +43,15 @@
+ # Makefile for sample config file
+ #
+
+-PREFIX=/usr/local/v6eval
+-ETCDIR=$(PREFIX)/etc
++PREFIX?=/usr/local
++ETCDIR=$(PREFIX)/v6eval/etc
+ SAMPLE=tn.def.sample nut.def.sample
+
+ all:
+
+ install:
+- install -d -o bin -g bin -m 755 $(ETCDIR)
+- install -c -o bin -g bin -m 644 $(SAMPLE) $(ETCDIR)
++ install -d -m 555 $(ETCDIR)
++ ${BSD_INSTALL_DATA} $(SAMPLE) $(ETCDIR)
+
+ depend:
+
diff --git a/net/v6eval/files/patch-include-Makefile b/net/v6eval/files/patch-include-Makefile
new file mode 100644
index 000000000000..ff80dac0e4d7
--- /dev/null
+++ b/net/v6eval/files/patch-include-Makefile
@@ -0,0 +1,27 @@
+--- include/Makefile.orig 2013-06-17 00:06:14.000000000 +0900
++++ include/Makefile 2013-06-17 00:18:39.000000000 +0900
+@@ -45,17 +45,17 @@
+ # Makefile for standard definition file
+ #
+
+-PREFIX=/usr/local/v6eval
+-INCLUDEDIR=$(PREFIX)/include/
++PREFIX?=/usr/local
++INCLUDEDIR=$(PREFIX)/v6eval/include/
+
+ all:
+
+ install:
+- install -d -o bin -g bin -m 755 $(INCLUDEDIR)
+- install -c -o bin -g bin -m 644 std.def $(INCLUDEDIR)
+- install -c -o bin -g bin -m 644 stdaddr.def $(INCLUDEDIR)
+- install -c -o bin -g bin -m 644 stdpacket.def $(INCLUDEDIR)
+- install -c -o bin -g bin -m 644 stdconst.def $(INCLUDEDIR)
++ install -d -m 555 $(INCLUDEDIR)
++ ${BSD_INSTALL_DATA} std.def $(INCLUDEDIR)
++ ${BSD_INSTALL_DATA} stdaddr.def $(INCLUDEDIR)
++ ${BSD_INSTALL_DATA} stdpacket.def $(INCLUDEDIR)
++ ${BSD_INSTALL_DATA} stdconst.def $(INCLUDEDIR)
+
+ depend:
+ clean:
diff --git a/net/v6eval/files/patch-sample-Makefile b/net/v6eval/files/patch-sample-Makefile
new file mode 100644
index 000000000000..010ff1beb68c
--- /dev/null
+++ b/net/v6eval/files/patch-sample-Makefile
@@ -0,0 +1,11 @@
+--- sample/Makefile.orig 2013-06-16 23:58:56.000000000 +0900
++++ sample/Makefile 2013-06-16 23:59:19.000000000 +0900
+@@ -2,7 +2,7 @@
+ # Makefile
+ #
+
+-AUTORUN=../bin/autorun/autorun
++AUTORUN= ${.CURDIR}/../bin/autorun
+
+ check:
+ $(AUTORUN) -t INDEX
diff --git a/net/v6eval/files/patch-script-pmod-V6evalCommon-V6evalCommon.pm b/net/v6eval/files/patch-script-pmod-V6evalCommon-V6evalCommon.pm
new file mode 100644
index 000000000000..1e552c6ad704
--- /dev/null
+++ b/net/v6eval/files/patch-script-pmod-V6evalCommon-V6evalCommon.pm
@@ -0,0 +1,11 @@
+--- script/pmod/V6evalCommon/V6evalCommon.pm.orig 2013-06-17 00:13:33.000000000 +0900
++++ script/pmod/V6evalCommon/V6evalCommon.pm 2013-06-17 00:19:20.000000000 +0900
+@@ -70,7 +70,7 @@
+ $path, # path
+ ) = @_;
+ ($SeqName,$SeqDir,$SeqSuffix) = fileparse($0,'.seq');
+- $V6EVALPREFIX= "/usr/local/v6eval";
++ $V6EVALPREFIX= "%%PREFIX%%/v6eval";
+ $V6EVALROOT = $path || $ENV{V6EVALROOT} || $V6EVALPREFIX;
+ $V6EVALBIN = $ENV{V6EVALBIN} || "$V6EVALROOT/bin/";
+ $V6EVALETC = $ENV{V6EVALETC} || "./:$V6EVALROOT/etc/";
diff --git a/net/v6eval/pkg-plist b/net/v6eval/pkg-plist
index fa3f9e67b58e..5a349f7185f4 100644
--- a/net/v6eval/pkg-plist
+++ b/net/v6eval/pkg-plist
@@ -126,15 +126,132 @@ v6eval/doc/00README
v6eval/doc/00README.v6eval
v6eval/doc/CHANGELOG
v6eval/doc/CHANGELOG.v6eval
-v6eval/doc/COPYRIGHT
v6eval/doc/INSTALL
v6eval/doc/INSTALL.v6eval
+v6eval/doc/INSTALL.dummies
v6eval/etc/nut.def.sample
v6eval/etc/tn.def.sample
v6eval/include/std.def
v6eval/include/stdaddr.def
v6eval/include/stdconst.def
v6eval/include/stdpacket.def
+v6eval/sample/64tunnel_ll_ping/packet.def
+v6eval/sample/64tunnel_ll_ping/ping.html
+v6eval/sample/64tunnel_ll_ping/ping.seq
+v6eval/sample/HBHoptAfterDstOpt/HBHoptAfterDstOpt.html
+v6eval/sample/HBHoptAfterDstOpt/HBHoptAfterDstOpt.seq
+v6eval/sample/HBHoptAfterDstOpt/packet.def
+v6eval/sample/INDEX
+v6eval/sample/Makefile
+v6eval/sample/jumbo/jumbo.html
+v6eval/sample/jumbo/jumbo.seq
+v6eval/sample/jumbo/packet.def
+v6eval/sample/mld-general/mld-general.html
+v6eval/sample/mld-general/mld-general.seq
+v6eval/sample/mld-general/packet.def
+v6eval/sample/na_w_mtu/na_w_mtu.html
+v6eval/sample/na_w_mtu/na_w_mtu.seq
+v6eval/sample/na_w_mtu/packet.def
+v6eval/sample/ping/packet.def
+v6eval/sample/ping/ping.html
+v6eval/sample/ping/ping.seq
+v6eval/sample/ping4/packet.def
+v6eval/sample/ping4/ping4.html
+v6eval/sample/ping4/ping4.seq
+v6eval/sample/ping_frag/packet.def
+v6eval/sample/ping_frag/ping_frag.html
+v6eval/sample/ping_frag/ping_frag.seq
+v6eval/sample/ping_from_many_host/packet.def
+v6eval/sample/ping_from_many_host/ping.html
+v6eval/sample/ping_from_many_host/ping.seq
+v6eval/sample/ping_glosite/packet.def
+v6eval/sample/ping_glosite/ping_glosite.html
+v6eval/sample/ping_glosite/ping_glosite.seq
+v6eval/sample/ping_w_ah/packet.def
+v6eval/sample/ping_w_ah/ping.html
+v6eval/sample/ping_w_ah/ping.seq
+v6eval/sample/ping_w_ah/setkey.cf
+v6eval/sample/ping_w_ahesp/packet.def
+v6eval/sample/ping_w_ahesp/ping.html
+v6eval/sample/ping_w_ahesp/ping.seq
+v6eval/sample/ping_w_ahesp/setkey.cf
+v6eval/sample/ping_w_esp/packet.def
+v6eval/sample/ping_w_esp/ping.html
+v6eval/sample/ping_w_esp/ping.seq
+v6eval/sample/ping_w_esp/setkey.cf
+v6eval/sample/ping_w_espicv/packet.def
+v6eval/sample/ping_w_espicv/ping.html
+v6eval/sample/ping_w_espicv/ping.seq
+v6eval/sample/ping_w_espicv/setkey.cf
+v6eval/sample/ping_w_espicvespicv/packet.def
+v6eval/sample/ping_w_espicvespicv/ping.html
+v6eval/sample/ping_w_espicvespicv/ping.seq
+v6eval/sample/ping_w_espicvespicv/setkey.cf
+v6eval/sample/portunreach/packet.def
+v6eval/sample/portunreach/portunreach.html
+v6eval/sample/portunreach/portunreach.seq
+v6eval/sample/redirect/packet.def
+v6eval/sample/redirect/redirect.html
+v6eval/sample/redirect/redirect.seq
+v6eval/sample/timeexceeded/packet.def
+v6eval/sample/timeexceeded/timeexceeded.html
+v6eval/sample/timeexceeded/timeexceeded.seq
+v6eval/sample/udpecho/packet.def
+v6eval/sample/udpecho/udpecho.html
+v6eval/sample/udpecho/udpecho.seq
+v6eval/sample/unknownnext/packet.def
+v6eval/sample/unknownnext/unknownnext.html
+v6eval/sample/unknownnext/unknownnext.seq
+v6eval/sample_stddef/SendRecv/Recv.seq
+v6eval/sample_stddef/SendRecv/Send.seq
+v6eval/sample_stddef/SendRecv/packet.def
+v6eval/sample_stddef/aes-ctr/aes-ctr.seq
+v6eval/sample_stddef/aes-ctr/packet.def
+v6eval/sample_stddef/igmp/igmpv3_test.def
+v6eval/sample_stddef/igmp/igmpv3_test.seq
+v6eval/sample_stddef/igmp/igmpv3_test.sh
+v6eval/sample_stddef/mldv2/mldv2_test.def
+v6eval/sample_stddef/mldv2/mldv2_test.seq
+v6eval/sample_stddef/mldv2/mldv2_test.sh
+v6eval/sample_stddef/ping_frag/packet.def
+v6eval/sample_stddef/ping_frag/ping_frag.seq
+v6eval/sample_stddef/ping_glosite/packet.def
+v6eval/sample_stddef/ping_glosite/ping_glosite.seq
+v6eval/sample_stddef/snmp/snmp.def
+v6eval/sample_stddef/snmp/snmp.seq
+v6eval/sample_stddef/snmp/snmp_sample.sh
+v6eval/sample_stddef/tcp_handshake/packet.def
+v6eval/sample_stddef/tcp_handshake/tcp_handshake.seq
+@dirrm v6eval/sample_stddef/tcp_handshake
+@dirrm v6eval/sample_stddef/snmp
+@dirrm v6eval/sample_stddef/ping_glosite
+@dirrm v6eval/sample_stddef/ping_frag
+@dirrm v6eval/sample_stddef/mldv2
+@dirrm v6eval/sample_stddef/igmp
+@dirrm v6eval/sample_stddef/aes-ctr
+@dirrm v6eval/sample_stddef/SendRecv
+@dirrm v6eval/sample_stddef
+@dirrm v6eval/sample/unknownnext
+@dirrm v6eval/sample/udpecho
+@dirrm v6eval/sample/timeexceeded
+@dirrm v6eval/sample/redirect
+@dirrm v6eval/sample/portunreach
+@dirrm v6eval/sample/ping_w_espicvespicv
+@dirrm v6eval/sample/ping_w_espicv
+@dirrm v6eval/sample/ping_w_esp
+@dirrm v6eval/sample/ping_w_ahesp
+@dirrm v6eval/sample/ping_w_ah
+@dirrm v6eval/sample/ping_glosite
+@dirrm v6eval/sample/ping_from_many_host
+@dirrm v6eval/sample/ping_frag
+@dirrm v6eval/sample/ping4
+@dirrm v6eval/sample/ping
+@dirrm v6eval/sample/na_w_mtu
+@dirrm v6eval/sample/mld-general
+@dirrm v6eval/sample/jumbo
+@dirrm v6eval/sample/HBHoptAfterDstOpt
+@dirrm v6eval/sample/64tunnel_ll_ping
+@dirrm v6eval/sample
@dirrm v6eval/bin/manual
@dirrm v6eval/bin/unknown
@dirrm v6eval/bin