aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-11-24 23:33:15 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-11-24 23:33:15 +0000
commit5c781a69e1a3e5d9acf28a64569259a7fe307f71 (patch)
tree8c903bc8d741ab96db2872d677ebc29b4374c700
parent19c16e88dd4af62a1ca01ef04a6e2b5e71e44a6c (diff)
downloadports-5c781a69e1a3e5d9acf28a64569259a7fe307f71.tar.gz
ports-5c781a69e1a3e5d9acf28a64569259a7fe307f71.zip
- svn mv www/mod_wsgi www/mod_wsgi2 [1]
- update ports to reflect new location - fix mod_wsgi3 build with python3 PR: 184065 [1] PR 183353 [2] Submitted by: Douglas William Thrift <douglas@douglasthrift.net> (maintainer)
Notes
Notes: svn path=/head/; revision=334797
-rw-r--r--MOVED1
-rw-r--r--UPDATING12
-rw-r--r--mail/automx/Makefile3
-rw-r--r--www/Makefile2
-rw-r--r--www/linkchecker/Makefile3
-rw-r--r--www/mod_wsgi2/Makefile (renamed from www/mod_wsgi/Makefile)3
-rw-r--r--www/mod_wsgi2/distinfo (renamed from www/mod_wsgi/distinfo)0
-rw-r--r--www/mod_wsgi2/files/pkg-message.in (renamed from www/mod_wsgi/files/pkg-message.in)0
-rw-r--r--www/mod_wsgi2/pkg-descr (renamed from www/mod_wsgi/pkg-descr)0
-rw-r--r--www/mod_wsgi2/pkg-plist (renamed from www/mod_wsgi/pkg-plist)0
-rw-r--r--www/mod_wsgi3/Makefile3
-rw-r--r--www/mod_wsgi3/files/patch-configure49
-rw-r--r--www/mod_wsgi3/files/patch-configure.ac50
13 files changed, 120 insertions, 6 deletions
diff --git a/MOVED b/MOVED
index 6192fa89c8c6..f3e74b75d284 100644
--- a/MOVED
+++ b/MOVED
@@ -5251,3 +5251,4 @@ audio/gstreamer1-plugins-celt||2013-11-20|Removed, audio/gstreamer1-plugins-opus
math/p5-MatrixReal|math/p5-Math-MatrixReal|2013-11-22|Rename to match upstream naming
lang/gcc42|lang/gcc46|2013-11-23|Superseded by GCC 4.6 or later
devel/p5-IO||2013-11-23|Removed: newer versions are included in all supported Perl releases
+www/mod_wsgi|www/mod_wsgi2|2013-11-24|Rename to match version
diff --git a/UPDATING b/UPDATING
index c1230a36bf7f..371d3bb622ec 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20131125:
+ AFFECTS: users of www/mod_wsgi
+ AUTHOR: ohauer@FreeBSD.org
+
+ The port www/mod_wsgi moved to www/mod_wsgi2 to reflect the port version.
+
+ # portmaster -o www/mod_wsgi2 www/mod_wsgi
+ or
+ # portupgrade -fo www/mod_wsgi2 www/mod_wsgi
+ or
+ # pkg set -o www/mod_wsgi:www/mod_wsgi2
+
20131120:
AFFECTS: users of lang/perl5.12 lang/perl5.14 lang/perl5.16 and lang/perl5.18
AUTHOR: mat@FreeBSD.org
diff --git a/mail/automx/Makefile b/mail/automx/Makefile
index ef43a347e972..14fc5689a7ad 100644
--- a/mail/automx/Makefile
+++ b/mail/automx/Makefile
@@ -2,6 +2,7 @@
PORTNAME= automx
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.automx.org/download/
@@ -10,7 +11,7 @@ COMMENT= Handles mail account profile requests from mail clients
LICENSE= GPLv3
-RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi \
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi2 \
${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
bash:${PORTSDIR}/shells/bash \
wget:${PORTSDIR}/ftp/wget
diff --git a/www/Makefile b/www/Makefile
index 88a2e907ee39..3c4f1485cc7a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -535,7 +535,7 @@
SUBDIR += mod_vhs
SUBDIR += mod_webkit
SUBDIR += mod_whatkilledus
- SUBDIR += mod_wsgi
+ SUBDIR += mod_wsgi2
SUBDIR += mod_wsgi3
SUBDIR += mod_xml2enc
SUBDIR += mod_xmlns
diff --git a/www/linkchecker/Makefile b/www/linkchecker/Makefile
index 72044046bb2f..cb1c808abf42 100644
--- a/www/linkchecker/Makefile
+++ b/www/linkchecker/Makefile
@@ -3,6 +3,7 @@
PORTNAME= linkchecker
PORTVERSION= 8.4
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= GHC
DISTNAME= LinkChecker-${PORTVERSION}
@@ -86,7 +87,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.5:${PORTSDIR}/www/py-cssutils
# To run the WSGI Web interface
.if ${PORT_OPTIONS:MWSGI}
-RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_wsg>0:${PORTSDIR}/www/mod_wsgi
+RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_wsg>0:${PORTSDIR}/www/mod_wsgi2
USE_APACHE_RUN= 22
.endif
diff --git a/www/mod_wsgi/Makefile b/www/mod_wsgi2/Makefile
index db7fb2462980..2365dd0c21ec 100644
--- a/www/mod_wsgi/Makefile
+++ b/www/mod_wsgi2/Makefile
@@ -7,14 +7,13 @@ PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
LICENSE= AL2
-
-LATEST_LINK= mod_wsgi2
CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi-3.* ${PKGNAMEPREFIX}mod_wsgi3.* mod_wsgi-3.*
PROJECTHOST= modwsgi
diff --git a/www/mod_wsgi/distinfo b/www/mod_wsgi2/distinfo
index 9ba00856ed60..9ba00856ed60 100644
--- a/www/mod_wsgi/distinfo
+++ b/www/mod_wsgi2/distinfo
diff --git a/www/mod_wsgi/files/pkg-message.in b/www/mod_wsgi2/files/pkg-message.in
index 5c72392ba9d4..5c72392ba9d4 100644
--- a/www/mod_wsgi/files/pkg-message.in
+++ b/www/mod_wsgi2/files/pkg-message.in
diff --git a/www/mod_wsgi/pkg-descr b/www/mod_wsgi2/pkg-descr
index 626edd10ab45..626edd10ab45 100644
--- a/www/mod_wsgi/pkg-descr
+++ b/www/mod_wsgi2/pkg-descr
diff --git a/www/mod_wsgi/pkg-plist b/www/mod_wsgi2/pkg-plist
index 45d83308c5b6..45d83308c5b6 100644
--- a/www/mod_wsgi/pkg-plist
+++ b/www/mod_wsgi2/pkg-plist
diff --git a/www/mod_wsgi3/Makefile b/www/mod_wsgi3/Makefile
index 1fcaa5907d23..3361a2bf0f5b 100644
--- a/www/mod_wsgi3/Makefile
+++ b/www/mod_wsgi3/Makefile
@@ -13,7 +13,8 @@ COMMENT= Python WSGI adapter module for Apache
LICENSE= AL2
-CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi-2.* mod_wsgi-2.*
+CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi2.* mod_wsgi2.* \
+ ${PKGNAMEPREFIX}mod_wsgi-2.* mod_wsgi-2.*
PROJECTHOST= modwsgi
diff --git a/www/mod_wsgi3/files/patch-configure b/www/mod_wsgi3/files/patch-configure
new file mode 100644
index 000000000000..f2724bd46005
--- /dev/null
+++ b/www/mod_wsgi3/files/patch-configure
@@ -0,0 +1,49 @@
+--- configure.orig Thu Oct 18 21:12:46 2012 +1100
++++ configure Thu Oct 18 21:14:28 2012 +1100
+@@ -1785,7 +1785,15 @@
+
+ PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+- stdout.write((sysconfig.get_config_var("VERSION")))'`
++ stdout.write(sysconfig.get_config_var("VERSION"))'`
++
++PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \
++ from distutils import sysconfig; \
++ stdout.write(sysconfig.get_config_var("LDVERSION") or "")'`
++
++if test x"${PYTHON_LDVERSION}" = x""; then
++ PYTHON_LDVERSION=${PYTHON_VERSION}
++fi
+
+ CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+@@ -1823,12 +1831,28 @@
+ from distutils import sysconfig; \
+ stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'`
+
++if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
++ PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
++fi
++
+ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
+ "${ENABLE_FRAMEWORK}" != "yes"; then
+ LDFLAGS1="-L${PYTHONLIBDIR}"
+ LDFLAGS2="-L${PYTHONCFGDIR}"
+
+- LDLIBS1="-lpython${PYTHON_VERSION}"
++ LDLIBS1="-lpython${PYTHON_LDVERSION}"
++
++ # MacOS X seems to be broken and doesn't use ABIFLAGS suffix
++ # so add a check to try and work out what we need to do.
++
++ if test -f "${PYTHONLIBDIR}/libpython${PYTHON_VERSION}.a"; then
++ LDLIBS1="-lpython${PYTHON_VERSION}"
++ fi
++
++ if test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
++ LDLIBS1="-lpython${PYTHON_VERSION}"
++ fi
++
+ LDLIBS2=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+ stdout.write(sysconfig.get_config_var("LIBS"))'`
diff --git a/www/mod_wsgi3/files/patch-configure.ac b/www/mod_wsgi3/files/patch-configure.ac
new file mode 100644
index 000000000000..ce7dfddea333
--- /dev/null
+++ b/www/mod_wsgi3/files/patch-configure.ac
@@ -0,0 +1,50 @@
+--- configure.ac.orig Thu Oct 18 21:12:46 2012 +1100
++++ configure.ac Thu Oct 18 21:14:28 2012 +1100
+@@ -75,7 +75,15 @@
+
+ PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+- stdout.write((sysconfig.get_config_var("VERSION")))'`
++ stdout.write(sysconfig.get_config_var("VERSION"))'`
++
++PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \
++ from distutils import sysconfig; \
++ stdout.write(sysconfig.get_config_var("LDVERSION") or "")'`
++
++if test x"${PYTHON_LDVERSION}" = x""; then
++ PYTHON_LDVERSION=${PYTHON_VERSION}
++fi
+
+ CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+@@ -113,12 +121,28 @@
+ from distutils import sysconfig; \
+ stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'`
+
++if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
++ PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
++fi
++
+ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
+ "${ENABLE_FRAMEWORK}" != "yes"; then
+ LDFLAGS1="-L${PYTHONLIBDIR}"
+ LDFLAGS2="-L${PYTHONCFGDIR}"
+
+- LDLIBS1="-lpython${PYTHON_VERSION}"
++ LDLIBS1="-lpython${PYTHON_LDVERSION}"
++
++ # MacOS X seems to be broken and doesn't use ABIFLAGS suffix
++ # so add a check to try and work out what we need to do.
++
++ if test -f "${PYTHONLIBDIR}/libpython${PYTHON_VERSION}.a"; then
++ LDLIBS1="-lpython${PYTHON_VERSION}"
++ fi
++
++ if test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
++ LDLIBS1="-lpython${PYTHON_VERSION}"
++ fi
++
+ LDLIBS2=`${PYTHON} -c 'from sys import stdout; \
+ from distutils import sysconfig; \
+ stdout.write(sysconfig.get_config_var("LIBS"))'`
+