aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-04-18 23:59:35 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-04-24 21:21:08 +0000
commit6471380236ca7307370a3cb0bfb957fd263db245 (patch)
tree0c0a11a95173c622b66f689532b05aaa98edbc58
parent0bb7044e0ec23afad4ae9b9fb1e138d052c0c09a (diff)
downloadports-6471380236ca7307370a3cb0bfb957fd263db245.tar.gz
ports-6471380236ca7307370a3cb0bfb957fd263db245.zip
misc/air: fix build on powerpc64le
cargo:warning=/usr/local/llvm15/lib/clang/15.0.7/include/ppc_wrappers/pmmintrin.h:35:2: error: "Please read comment above. Use -DNO_WARN_X86_INTRINSICS to disable this warning."
-rw-r--r--misc/air/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/misc/air/Makefile b/misc/air/Makefile
index 2e9002e90045..8893fbf32e9b 100644
--- a/misc/air/Makefile
+++ b/misc/air/Makefile
@@ -210,6 +210,8 @@ CARGO_CRATES= addr2line-0.21.0 \
windows_x86_64_msvc-0.52.0 \
winreg-0.50.0
+CFLAGS_powerpc64le= -DNO_WARN_X86_INTRINSICS
+
OPENSSLINC= /usr/include
OPENSSLLIB= /usr/lib