aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-04-25 00:39:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-04-25 00:48:17 +0000
commitb74febdcf13b52b2e168a75c49549229fa7f283a (patch)
tree9cb3998997d1bbe9339b6b2b58f43b3f37602967
parentea1635d6dcf85882b1209bdef40f16fd6266a0ed (diff)
downloadports-b74febdcf13b52b2e168a75c49549229fa7f283a.tar.gz
ports-b74febdcf13b52b2e168a75c49549229fa7f283a.zip
deskutils/health: unbreak build on i386
fatal runtime error: Rust cannot catch foreign exceptions thread 'coordinator' panicked at compiler/rustc_middle/src/util/bug.rs:36:26: /wrkdirs/usr/ports/lang/rust/work/rustc-1.77.0-src/compiler/rustc_codegen_ssa/src/back/write.rs:1588:29: worker thread panicked (signal: 6, SIGABRT: process abort signal) Reported by: pkg-fallout
-rw-r--r--deskutils/health/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/deskutils/health/Makefile b/deskutils/health/Makefile
index a0c570797eba..79c59e3239e2 100644
--- a/deskutils/health/Makefile
+++ b/deskutils/health/Makefile
@@ -27,6 +27,12 @@ CARGO_INSTALL= no
CARGO_TEST= no
GLIB_SCHEMAS= dev.Cogitri.Health.gschema.xml
+.if ${MACHINE_ARCH} == i386
+# https://github.com/rust-lang/rust/issues/85598
+LTO_UNSAFE= yes
+CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO=false
+.endif
+
post-patch:
# Make each cargo subcommand very verbose
# Add explicit <triple> subdir for --target from USES=cargo