aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/health/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/deskutils/health/Makefile b/deskutils/health/Makefile
index a0c570797eba..79c59e3239e2 100644
--- a/deskutils/health/Makefile
+++ b/deskutils/health/Makefile
@@ -27,6 +27,12 @@ CARGO_INSTALL= no
CARGO_TEST= no
GLIB_SCHEMAS= dev.Cogitri.Health.gschema.xml
+.if ${MACHINE_ARCH} == i386
+# https://github.com/rust-lang/rust/issues/85598
+LTO_UNSAFE= yes
+CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO=false
+.endif
+
post-patch:
# Make each cargo subcommand very verbose
# Add explicit <triple> subdir for --target from USES=cargo