aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-10 08:47:13 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-10 08:47:13 +0000
commitbd88a72aebfa3df7eb3978bf43ee07ef9df360a0 (patch)
treed9231f59eb51b6706616d4f24919d4e36a47c28e
parent893841946a8dbc80f42aa662d49fc6e0f3b1a7e6 (diff)
downloadports-bd88a72aebfa3df7eb3978bf43ee07ef9df360a0.tar.gz
ports-bd88a72aebfa3df7eb3978bf43ee07ef9df360a0.zip
MFH: r445228
Update PHP 7.1 from 7.1.6 to 7.1.7 Changelog: http://www.php.net/ChangeLog-7.php#7.1.7 PR: 220532 Reported by: Fabiano Sidler <fabianosidler@swissonline.ch>, Dani <i.dani@outlook.com> Security: CVE-2017-9224 Security: CVE-2017-9226 Security: CVE-2017-9227 Security: CVE-2017-9228 Security: CVE-2017-9229 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2017Q3/; revision=445419
-rw-r--r--devel/php71-readline/Makefile1
-rw-r--r--lang/php71/Makefile4
-rw-r--r--lang/php71/distinfo6
-rw-r--r--lang/php71/files/patch-main_php__ini.c40
-rw-r--r--www/php71-opcache/Makefile1
5 files changed, 5 insertions, 47 deletions
diff --git a/devel/php71-readline/Makefile b/devel/php71-readline/Makefile
index 3a182ab59e4c..e42513610a12 100644
--- a/devel/php71-readline/Makefile
+++ b/devel/php71-readline/Makefile
@@ -1,6 +1,5 @@
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php71
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index 0faa5258300e..867fc00ce03c 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= php71
-PORTVERSION= 7.1.6
-PORTREVISION?= 1
+PORTVERSION= 7.1.7
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php71/distinfo b/lang/php71/distinfo
index d6441897271a..ca8e91cba9ab 100644
--- a/lang/php71/distinfo
+++ b/lang/php71/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497260087
-SHA256 (php-7.1.6.tar.xz) = 01584dc521ab7ec84b502b61952f573652fe6aa00c18d6d844fb9209f14b245b
-SIZE (php-7.1.6.tar.xz) = 12808680
+TIMESTAMP = 1499416423
+SHA256 (php-7.1.7.tar.xz) = 0d42089729be7b2bb0308cbe189c2782f9cb4b07078c8a235495be5874fff729
+SIZE (php-7.1.7.tar.xz) = 12831708
diff --git a/lang/php71/files/patch-main_php__ini.c b/lang/php71/files/patch-main_php__ini.c
deleted file mode 100644
index c951481c791b..000000000000
--- a/lang/php71/files/patch-main_php__ini.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- main/php_ini.c.orig 2017-06-14 13:23:49 UTC
-+++ main/php_ini.c
-@@ -280,7 +280,7 @@ static void php_ini_parser_cb(zval *arg1
- size_t key_len;
-
- /* PATH sections */
-- if (zend_string_equals_literal_ci(Z_STR_P(arg1), "PATH")) {
-+ if (!zend_binary_strncasecmp(Z_STRVAL_P(arg1), Z_STRLEN_P(arg1), "PATH", sizeof("PATH") - 1, sizeof("PATH") - 1)) {
- key = Z_STRVAL_P(arg1);
- key = key + sizeof("PATH") - 1;
- key_len = Z_STRLEN_P(arg1) - sizeof("PATH") + 1;
-@@ -291,7 +291,7 @@ static void php_ini_parser_cb(zval *arg1
- TRANSLATE_SLASHES_LOWER(key);
-
- /* HOST sections */
-- } else if (zend_string_equals_literal_ci(Z_STR_P(arg1), "HOST")) {
-+ } else if (!zend_binary_strncasecmp(Z_STRVAL_P(arg1), Z_STRLEN_P(arg1), "HOST", sizeof("HOST") - 1, sizeof("HOST") - 1)) {
- key = Z_STRVAL_P(arg1);
- key = key + sizeof("HOST") - 1;
- key_len = Z_STRLEN_P(arg1) - sizeof("HOST") + 1;
-@@ -328,7 +328,9 @@ static void php_ini_parser_cb(zval *arg1
- zend_hash_init(Z_ARRVAL(section_arr), 8, NULL, (dtor_func_t) config_zval_dtor, 1);
- entry = zend_hash_str_update(target_hash, key, key_len, &section_arr);
- }
-- active_ini_hash = Z_ARRVAL_P(entry);
-+ if (Z_TYPE_P(entry) == IS_ARRAY) {
-+ active_ini_hash = Z_ARRVAL_P(entry);
-+ }
- }
- }
- break;
-@@ -638,7 +640,7 @@ int php_init_config(void)
- }
- if (!debpath[0]) {
- /* empty string means default builtin value
-- to allow "/foo/php.d:" or ":/foo/php.d" */
-+ to allow "/foo/phd.d:" or ":/foo/php.d" */
- debpath = PHP_CONFIG_FILE_SCAN_DIR;
- }
- lenpath = (int)strlen(debpath);
diff --git a/www/php71-opcache/Makefile b/www/php71-opcache/Makefile
index 03545e582cf6..6a991ff1b4f9 100644
--- a/www/php71-opcache/Makefile
+++ b/www/php71-opcache/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
CATEGORIES= www
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php71