aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-06-18 17:46:30 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-06-18 17:46:30 +0000
commitcbc090bfe388feff63969503dd3c6c9004c8dc6b (patch)
treead3188d35580628f258de0dc4d3d2e98d040ab55
parent5bae44dae0b82bdfca7744c4499dcb24feda1032 (diff)
Notes
-rw-r--r--Mk/Uses/cran.mk9
-rw-r--r--math/R-cran-MCMCpack/Makefile4
-rw-r--r--math/R-cran-RcppArmadillo/Makefile3
-rw-r--r--math/R/Makefile2
-rw-r--r--math/R/compiler.mk2
5 files changed, 12 insertions, 8 deletions
diff --git a/Mk/Uses/cran.mk b/Mk/Uses/cran.mk
index 1824ca6f0ec2..b63d76c73489 100644
--- a/Mk/Uses/cran.mk
+++ b/Mk/Uses/cran.mk
@@ -4,9 +4,10 @@
#
# Feature: cran
# Usage: USES=cran or USES=cran:ARGS
-# Valid ARGS: auto-plist
+# Valid ARGS: auto-plist, compiles
#
-# auto-plist The pkg-plist can be automatically compiled
+# auto-plist The pkg-plist is to be automatically generated
+# compiles The port has code that needs to be compiled
#
# MAINTAINER= wen@FreeBSD.org
@@ -76,4 +77,8 @@ cran-auto-plist:
${SED} -E -e 's,^${STAGEDIR}${PREFIX}/?,,' >> ${TMPPLIST}
.endif
+.if ${cran_ARGS:Mcompiles}
+.include "${PORTSDIR}/math/R/compiler.mk"
+.endif
+
.endif #_INCLUDE_USES_CRAN_MK
diff --git a/math/R-cran-MCMCpack/Makefile b/math/R-cran-MCMCpack/Makefile
index dc33fbf468ae..6bc975bc9795 100644
--- a/math/R-cran-MCMCpack/Makefile
+++ b/math/R-cran-MCMCpack/Makefile
@@ -14,8 +14,6 @@ LICENSE= GPLv3
RUN_DEPENDS= R-cran-coda>0.11.3:math/R-cran-coda
-# Actually required 4.0 or later.
-USE_GCC= any
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/math/R-cran-RcppArmadillo/Makefile b/math/R-cran-RcppArmadillo/Makefile
index 557cb2f7d79c..042e52041746 100644
--- a/math/R-cran-RcppArmadillo/Makefile
+++ b/math/R-cran-RcppArmadillo/Makefile
@@ -13,7 +13,6 @@ LICENSE= GPLv2+
RUN_DEPENDS= R-cran-Rcpp>=0.11.0:devel/R-cran-Rcpp
-USES= cran:auto-plist
-USE_GCC= yes
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/math/R/Makefile b/math/R/Makefile
index 9bba13b53bd1..2988d60bedd9 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -107,8 +107,8 @@ RBLAS_SOVERSION= 2
RLAPACK_SOVERSION= 4
RMATH_SOVERSION= 0
USES+= fortran
-USE_GCC= yes
+.include "${.CURDIR}/compiler.mk"
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64" || ${ARCH} == "powerpc64"
diff --git a/math/R/compiler.mk b/math/R/compiler.mk
new file mode 100644
index 000000000000..6a3352b0d345
--- /dev/null
+++ b/math/R/compiler.mk
@@ -0,0 +1,2 @@
+# Compiler settings required for R and the R-cran ports.
+USE_GCC= yes