aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-04-12 05:43:16 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-04-12 05:43:16 +0000
commitd7ee2f88c5a8233b0fc8c3c6e6c79f4ea14b54e0 (patch)
treea44dff7b8ff97d5d6d87d337b2106ea523604c04
parentfd4835a1191f21ec43716b0591fe3b9d3105cf35 (diff)
Notes
-rw-r--r--databases/db48/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index 3ccbc9ecee7b..806ce6cea9fd 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -16,10 +16,9 @@ COMMENT= Berkeley DB package, revision 4.8
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE
-DEPRECATED= Please migrate to db5 or db6
-# The port is not to be removed unless the bitcoin-related ports can
-# go without this.
-EXPIRATION_DATE= 2016-07-31
+DEPRECATED= Please migrate to db5 or db6, make sure that bitcoin and siblings moved to another database or version by then
+# This port expires along with FreeBSD 10.X.
+EXPIRATION_DATE= 2018-04-30
BDBVER= ${PORTVERSION:R:R}
CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
@@ -35,6 +34,10 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100101
+IGNORE= db48 is not supported on FreeBSD 11+ with clang 3.8 - upgrade to db5
+.endif
+
.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db48 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
@@ -42,7 +45,6 @@ CONFIGURE_ARGS+= --enable-posixmutexes
post-patch:
${REINPLACE_CMD} -Ee 's|--mode=install cp -p|--mode=install ${INSTALL} -s|;' ${WRKSRC}/${CONFIGURE_SCRIPT}
- ${REINPLACE_CMD} -Ee 's/[[:<:]]atomic_init[[:>:]]/db_atomic_init/g' ${WRKSRC}/../dbinc/atomic.h ${WRKSRC}/../mp/mp_*.c ${WRKSRC}/../mutex/mut_*.c
post-install:
.for i in libdb libdb_cxx