aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-22 21:51:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-22 21:51:59 +0000
commitda6546de6f6e11114e278090bead634b05a6a6ef (patch)
tree9e0abe96af95fdcdd6dadf6d7b726eab4ddf6020
parentc230edc9ce37587f4cd7cbb0cee74f1266dc8921 (diff)
downloadports-da6546de6f6e11114e278090bead634b05a6a6ef.tar.gz
ports-da6546de6f6e11114e278090bead634b05a6a6ef.zip
Notes
-rw-r--r--textproc/colordiff/Makefile15
-rw-r--r--textproc/colordiff/pkg-plist1
-rw-r--r--textproc/fldiff/Makefile14
-rw-r--r--textproc/fldiff/pkg-plist1
-rw-r--r--textproc/htmlise/Makefile3
-rw-r--r--textproc/rtf2html/Makefile3
-rw-r--r--textproc/uni2ascii/Makefile9
-rw-r--r--textproc/xlreader/Makefile3
-rw-r--r--textproc/xmlindent/Makefile8
9 files changed, 24 insertions, 33 deletions
diff --git a/textproc/colordiff/Makefile b/textproc/colordiff/Makefile
index ade70bc014ea..4cfa9521c93a 100644
--- a/textproc/colordiff/Makefile
+++ b/textproc/colordiff/Makefile
@@ -16,18 +16,15 @@ NO_BUILD= yes
SHEBANG_FILES= colordiff.pl
-MAN1= colordiff.1
-
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${MAN1}
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${PREFIX}/etc/colordiffrc.default
-.if !exists(${PREFIX}/etc/colordiffrc)
- ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${PREFIX}/etc
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${STAGEDIR}${PREFIX}/etc/colordiffrc.default
+.if !exists(${STAGEDIR}${PREFIX}/etc/colordiffrc)
+ ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${STAGEDIR}${PREFIX}/etc
.endif
.include <bsd.port.mk>
diff --git a/textproc/colordiff/pkg-plist b/textproc/colordiff/pkg-plist
index c6e4e6997b57..22dbae8eed38 100644
--- a/textproc/colordiff/pkg-plist
+++ b/textproc/colordiff/pkg-plist
@@ -1,4 +1,5 @@
bin/colordiff
+man/man1/colordiff.1.gz
@unexec if cmp -s %D/etc/colordiffrc %D/etc/colordiffrc.default; then rm -f %D/etc/colordiffrc; fi
etc/colordiffrc.default
@exec [ -f %B/colordiffrc ] || cp %B/%f %B/colordiffrc
diff --git a/textproc/fldiff/Makefile b/textproc/fldiff/Makefile
index 1758523be70c..12dbe700abb0 100644
--- a/textproc/fldiff/Makefile
+++ b/textproc/fldiff/Makefile
@@ -20,12 +20,10 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN1= fldiff.1
PORTDOCS= index.html fldiff.jpg
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -34,13 +32,13 @@ post-patch:
${WRKSRC}/fldiff.desktop
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fldiff ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/fldiff.man ${MAN1PREFIX}/man/man1/fldiff.1
- ${INSTALL_DATA} ${WRKSRC}/fldiff.desktop ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/fldiff.png ${PREFIX}/share/pixmaps
+ ${INSTALL_PROGRAM} ${WRKSRC}/fldiff ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fldiff.man ${STAGEDIR}${MAN1PREFIX}/man/man1/fldiff.1
+ ${INSTALL_DATA} ${WRKSRC}/fldiff.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/fldiff.png ${STAGEDIR}${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/fldiff/pkg-plist b/textproc/fldiff/pkg-plist
index b162140328d2..bf337c5e2a48 100644
--- a/textproc/fldiff/pkg-plist
+++ b/textproc/fldiff/pkg-plist
@@ -1,3 +1,4 @@
bin/fldiff
+man/man1/fldiff.1.gz
share/applications/fldiff.desktop
share/pixmaps/fldiff.png
diff --git a/textproc/htmlise/Makefile b/textproc/htmlise/Makefile
index 11594cf84098..e5d70e726941 100644
--- a/textproc/htmlise/Makefile
+++ b/textproc/htmlise/Makefile
@@ -15,7 +15,6 @@ TABSIZE?= 8
SRC= htmlise tables markup inline
PLIST_FILES= bin/htmlise
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|\(TABSIZE\ \)[0-9]*|\1${TABSIZE}|' \
${WRKSRC}/${PORTNAME}.h
@@ -27,6 +26,6 @@ do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${SRC:C/(.*)/${WRKSRC}\/\1.o/}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/textproc/rtf2html/Makefile b/textproc/rtf2html/Makefile
index ad113081709b..6c9121bb0bee 100644
--- a/textproc/rtf2html/Makefile
+++ b/textproc/rtf2html/Makefile
@@ -13,11 +13,10 @@ PLIST_FILES= bin/rtf2html
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
do-build:
${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/textproc/uni2ascii/Makefile b/textproc/uni2ascii/Makefile
index e45d20ed4fc6..564b64edf50b 100644
--- a/textproc/uni2ascii/Makefile
+++ b/textproc/uni2ascii/Makefile
@@ -17,14 +17,13 @@ USE_BZIP2= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= uni2ascii.1 ascii2uni.1
-PLIST_FILES= bin/uni2ascii bin/ascii2uni
+PLIST_FILES= bin/uni2ascii bin/ascii2uni man/man1/uni2ascii.1.gz \
+ man/man1/ascii2uni.1.gz
-NO_STAGE= yes
do-install:
.for f in ${PORTNAME} ascii2uni
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.endfor
.include <bsd.port.mk>
diff --git a/textproc/xlreader/Makefile b/textproc/xlreader/Makefile
index cfbb661248d8..c944f33b7db9 100644
--- a/textproc/xlreader/Makefile
+++ b/textproc/xlreader/Makefile
@@ -12,13 +12,12 @@ COMMENT= Convert .xls spread sheets to tab delimited CSV or SQL inserts
PLIST_FILES= bin/xlreader
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|-L/usr/local/lib||; s|^CFLAGS=.*||; s|gcc|${CC}|' \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/textproc/xmlindent/Makefile b/textproc/xmlindent/Makefile
index 66262d4a183f..5fe618544c8d 100644
--- a/textproc/xmlindent/Makefile
+++ b/textproc/xmlindent/Makefile
@@ -16,17 +16,15 @@ MANCOMPRESSED= no
SOURCES= error.c indent.c buffer.c main.c
-MAN1= xmlindent.1
-PLIST_FILES= bin/xmlindent
+PLIST_FILES= bin/xmlindent man/man1/xmlindent.1.gz
-NO_STAGE= yes
do-build:
@cd ${WRKSRC}; flex xmlindent.yy
${CC} ${CFLAGS} ${SOURCES:C/(.*)/${WRKSRC}\/\1/} \
-o ${WRKSRC}/${PORTNAME} -lfl
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>