aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-04-21 20:32:22 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-04-21 20:33:42 +0000
commiteb0f7f193a3774afd3863731e1a926730e2f81d8 (patch)
tree901f74f8ebf66f6539f6c95b7e37e520e2fc4ed9
parent47340329e7b677aabf7caae900878c61c04f3b73 (diff)
downloadports-eb0f7f193a3774afd3863731e1a926730e2f81d8.tar.gz
ports-eb0f7f193a3774afd3863731e1a926730e2f81d8.zip
x11-clocks/catclock: Add new port: Kit-cat xclock
-rw-r--r--x11-clocks/Makefile1
-rw-r--r--x11-clocks/catclock/Makefile37
-rw-r--r--x11-clocks/catclock/distinfo3
-rw-r--r--x11-clocks/catclock/pkg-descr4
4 files changed, 45 insertions, 0 deletions
diff --git a/x11-clocks/Makefile b/x11-clocks/Makefile
index 544c6c595d1c..ea620803a5f5 100644
--- a/x11-clocks/Makefile
+++ b/x11-clocks/Makefile
@@ -11,6 +11,7 @@
SUBDIR += bclock
SUBDIR += buici-clock
SUBDIR += cairo-clock
+ SUBDIR += catclock
SUBDIR += dclock
SUBDIR += emiclock
SUBDIR += eyeclock
diff --git a/x11-clocks/catclock/Makefile b/x11-clocks/catclock/Makefile
new file mode 100644
index 000000000000..ee54201a30d5
--- /dev/null
+++ b/x11-clocks/catclock/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= catclock
+PORTVERSION= g20200328
+CATEGORIES= x11-clocks
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Kit-cat xclock
+
+LICENSE= MIT
+
+USES= localbase:ldflags motif xorg
+USE_GITHUB= yes
+GH_ACCOUNT= BarkyTheDog
+GH_TAGNAME= 9de77d05e04bc463bdbd8cfe1f9247042369e3f9
+USE_XORG= x11 xext xt
+
+CFLAGS+= -I${LOCALBASE}/include/X11
+LIBS+= -lX11 ${MOTIFLIB} -lXt -lXext -lm
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1.gz
+PORTDOCS= README.md readme_original
+PORTEXAMPLES= xclock.ad
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${LIBS} -o ${PORTNAME} *.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xclock.man ${STAGEDIR}${PREFIX}/share/man/man1/${PORTNAME}.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/catclock/distinfo b/x11-clocks/catclock/distinfo
new file mode 100644
index 000000000000..2e5211cd6137
--- /dev/null
+++ b/x11-clocks/catclock/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619018232
+SHA256 (BarkyTheDog-catclock-g20200328-9de77d05e04bc463bdbd8cfe1f9247042369e3f9_GH0.tar.gz) = 97d3b53a3f4d71c9765b6e7c100de199e74b03b96978d221f05b8f5fd3e739a7
+SIZE (BarkyTheDog-catclock-g20200328-9de77d05e04bc463bdbd8cfe1f9247042369e3f9_GH0.tar.gz) = 58891
diff --git a/x11-clocks/catclock/pkg-descr b/x11-clocks/catclock/pkg-descr
new file mode 100644
index 000000000000..10fde751985b
--- /dev/null
+++ b/x11-clocks/catclock/pkg-descr
@@ -0,0 +1,4 @@
+This is a version of the X Window System xclock program, which has been
+enhanced with a "cat mode".
+
+WWW: https://github.com/BarkyTheDog/catclock