aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-24 06:25:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-24 06:25:45 +0000
commitec2a43759eac441a0872e9cd6be414e5a417c167 (patch)
treef7c389bc3da0a14d87433fd4ec3ccb05d85929ad
parente8f840657f4fc44d11e81c8cc796396faac9c441 (diff)
downloadports-ec2a43759eac441a0872e9cd6be414e5a417c167.tar.gz
ports-ec2a43759eac441a0872e9cd6be414e5a417c167.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/soundconverter/Makefile34
-rw-r--r--audio/soundconverter/distinfo3
-rw-r--r--audio/soundconverter/pkg-descr7
-rw-r--r--audio/soundconverter/pkg-plist47
5 files changed, 92 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8c27cb30969e..52b98fcdfa35 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -587,6 +587,7 @@
SUBDIR += sonata
SUBDIR += sonice
SUBDIR += sound-juicer
+ SUBDIR += soundconverter
SUBDIR += soundgrab
SUBDIR += soundtouch
SUBDIR += soundtracker
diff --git a/audio/soundconverter/Makefile b/audio/soundconverter/Makefile
new file mode 100644
index 000000000000..1319319a77bd
--- /dev/null
+++ b/audio/soundconverter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: soundconverter
+# Date created: 04 September 2007
+# Whom: Jona Joachim <jaj@hcl-club.lu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soundconverter
+PORTVERSION= 0.9.7
+CATEGORIES= audio python
+MASTER_SITES= BERLIOS
+#MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jaj@hcl-club.lu
+COMMENT= The sound conversion application for the GNOME environment
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gst-0.10/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_GNOME= pygtk2 pygnome2
+
+MAKE_ENV= MAKE=${LOCALBASE}/bin/gmake
+
+INSTALLS_ICONS= yes
+MAN1= soundconverter.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@GMSGFMT@|${LOCALBASE}/bin/msgfmt|' ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/python|#!/usr/bin/env python|' ${WRKSRC}/src/soundconverter.py
+
+.include <bsd.port.mk>
diff --git a/audio/soundconverter/distinfo b/audio/soundconverter/distinfo
new file mode 100644
index 000000000000..ee0b9142fdce
--- /dev/null
+++ b/audio/soundconverter/distinfo
@@ -0,0 +1,3 @@
+MD5 (soundconverter-0.9.7.tar.gz) = df186bab81d58680617bc9f401f5a793
+SHA256 (soundconverter-0.9.7.tar.gz) = 00efca0113d39ef51b5fa3395d08958763286ee4f9805dae69c35686667f2d61
+SIZE (soundconverter-0.9.7.tar.gz) = 229507
diff --git a/audio/soundconverter/pkg-descr b/audio/soundconverter/pkg-descr
new file mode 100644
index 000000000000..168b059bdd08
--- /dev/null
+++ b/audio/soundconverter/pkg-descr
@@ -0,0 +1,7 @@
+SoundConverter is the sound conversion application for the GNOME
+environment. It reads anything the GStreamer library can read
+(Ogg Vorbis, AAC, MP3, FLAC, WAV, AVI, MPEG, MOV, M4A, AC3, DTS,
+ALAC, MPC, Shorten, APE, SID, etc...), and writes WAV, FLAC, MP3,
+and Ogg Vorbis files.
+
+WWW: http://soundconverter.berlios.de/
diff --git a/audio/soundconverter/pkg-plist b/audio/soundconverter/pkg-plist
new file mode 100644
index 000000000000..376967f8fd6a
--- /dev/null
+++ b/audio/soundconverter/pkg-plist
@@ -0,0 +1,47 @@
+bin/soundconverter
+lib/locale/cs/LC_MESSAGES/soundconverter.mo
+lib/locale/de/LC_MESSAGES/soundconverter.mo
+lib/locale/es/LC_MESSAGES/soundconverter.mo
+lib/locale/fr/LC_MESSAGES/soundconverter.mo
+lib/locale/hu/LC_MESSAGES/soundconverter.mo
+lib/locale/it/LC_MESSAGES/soundconverter.mo
+lib/locale/pl/LC_MESSAGES/soundconverter.mo
+lib/locale/pt_BR/LC_MESSAGES/soundconverter.mo
+lib/locale/ru/LC_MESSAGES/soundconverter.mo
+lib/locale/sv_SE/LC_MESSAGES/soundconverter.mo
+share/applications/soundconverter.desktop
+share/icons/hicolor/48x48/apps/soundconverter.png
+share/icons/hicolor/scalable/apps/soundconverter.svg
+%%DATADIR%%/soundconverter-logo.svg
+%%DATADIR%%/soundconverter.glade
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications
+@dirrm lib/locale/sv_SE/LC_MESSAGES
+@dirrm lib/locale/sv_SE
+@dirrm lib/locale/ru/LC_MESSAGES
+@dirrm lib/locale/ru
+@dirrm lib/locale/pt_BR/LC_MESSAGES
+@dirrm lib/locale/pt_BR
+@dirrm lib/locale/pl/LC_MESSAGES
+@dirrm lib/locale/pl
+@dirrm lib/locale/it/LC_MESSAGES
+@dirrm lib/locale/it
+@dirrm lib/locale/hu/LC_MESSAGES
+@dirrm lib/locale/hu
+@dirrm lib/locale/fr/LC_MESSAGES
+@dirrm lib/locale/fr
+@dirrm lib/locale/es/LC_MESSAGES
+@dirrm lib/locale/es
+@dirrm lib/locale/de/LC_MESSAGES
+@dirrm lib/locale/de
+@dirrm lib/locale/cs/LC_MESSAGES
+@dirrm lib/locale/cs
+@dirrm lib/locale
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true