aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-18 14:28:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-18 14:28:46 +0000
commit2ae03d48e767ca43307d1b4a890e3b47e8525391 (patch)
treea783c83f45f0b5fb2ae7717b9b42af558c2b3749 /Makefile
parent931cab63a3e6c547fc2b3727d152f0483dc9f31e (diff)
downloadports-2ae03d48e767ca43307d1b4a890e3b47e8525391.tar.gz
ports-2ae03d48e767ca43307d1b4a890e3b47e8525391.zip
- Terminate support for X11BASE having different value from LOCALBASE
PR: ports/122341 Submitted by: flz
Notes
Notes: svn path=/head/; revision=246154
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index eb3e6443b95c..4c061017d559 100644
--- a/Makefile
+++ b/Makefile
@@ -106,8 +106,6 @@ ${INDEXDIR}/${INDEXFILE}:
@${INDEX_ECHO_1ST} "Generating ${INDEXFILE} - please wait.."; \
if [ "${INDEX_PRISTINE}" != "" ]; then \
export LOCALBASE=/nonexistentlocal; \
- export X11BASE=/nonexistentx; \
- export USE_NONDEFAULT_X11BASE=1; \
fi; \
tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
@@ -140,8 +138,7 @@ ${INDEXDIR}/${INDEXFILE}:
sort -t '|' +1 -2 | \
sed -e 's../.g' > ${INDEXDIR}/${INDEXFILE}.tmp; \
if [ "${INDEX_PRISTINE}" != "" ]; then \
- sed -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," \
- ${INDEXDIR}/${INDEXFILE}.tmp > ${INDEXDIR}/${INDEXFILE}; \
+ sed -e "s,$${LOCALBASE},/usr/local," ${INDEXDIR}/${INDEXFILE}.tmp > ${INDEXDIR}/${INDEXFILE}; \
else \
mv ${INDEXDIR}/${INDEXFILE}.tmp ${INDEXDIR}/${INDEXFILE}; \
fi; \