aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2023-09-16 13:03:28 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-09-16 13:03:28 +0000
commita893761fe52a3fbf5931d90b334b8ae9738ba50a (patch)
treec36ace622f531336812b4b185edf2e5f11fe4dbb /Mk
parent6ee2f597f5828bbceffbc3e90c844e77626a07f8 (diff)
downloadports-a893761fe52a3fbf5931d90b334b8ae9738ba50a.tar.gz
ports-a893761fe52a3fbf5931d90b334b8ae9738ba50a.zip
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index ec8804fa3c09..037e711c62df 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -110,15 +110,14 @@ LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME} -L${_GCC_RUNTIME}
CFLAGS:= ${CFLAGS:N-mretpoline}
CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-. if defined(_GCC_PORT)
BUILD_DEPENDS+= ${CC}:lang/${_GCC_PORT}
-. if defined(_USE_GCC_RUN_DEPENDS)
+. if defined(_USE_GCC_RUN_DEPENDS)
RUN_DEPENDS+= ${CC}:lang/${_GCC_PORT}
-. endif
+. endif
+
# GCC ports already depend on binutils; make sure whatever we build
# leverages this as well.
USE_BINUTILS= yes
-. endif
.endif # defined(_USE_GCC) && !defined(FORCE_BASE_CC_FOR_TESTING)