aboutsummaryrefslogtreecommitdiff
path: root/archivers/hs-zlib
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-04 21:24:37 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-04 21:24:37 +0000
commit586d14085131929419d875f284b686a4251a8e83 (patch)
tree791b1fb627dddf84365336db6a7eb5e876682aaf /archivers/hs-zlib
parentebb7c8c54bf5d16c5c6798694c6d46767edc5de8 (diff)
downloadports-586d14085131929419d875f284b686a4251a8e83.tar.gz
ports-586d14085131929419d875f284b686a4251a8e83.zip
Notes
Diffstat (limited to 'archivers/hs-zlib')
-rw-r--r--archivers/hs-zlib/Makefile37
-rw-r--r--archivers/hs-zlib/distinfo3
-rw-r--r--archivers/hs-zlib/pkg-descr8
-rw-r--r--archivers/hs-zlib/pkg-plist18
4 files changed, 66 insertions, 0 deletions
diff --git a/archivers/hs-zlib/Makefile b/archivers/hs-zlib/Makefile
new file mode 100644
index 000000000000..aec9622e197b
--- /dev/null
+++ b/archivers/hs-zlib/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: zlib
+# Date created: November 2, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= zlib
+PORTVERSION= 0.5.0.0
+CATEGORIES= archivers haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://kerneled.org/tmp/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Pure Haskell interface to the C zlib library
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.hs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/archivers/hs-zlib/distinfo b/archivers/hs-zlib/distinfo
new file mode 100644
index 000000000000..32a2ff8fd31f
--- /dev/null
+++ b/archivers/hs-zlib/distinfo
@@ -0,0 +1,3 @@
+MD5 (zlib-0.5.0.0.tar.gz) = 22fa6d394c42c8584b234799b923f860
+SHA256 (zlib-0.5.0.0.tar.gz) = 20e067cfbec87ec062ac144875a60e158ea6cf7836aac031ec367fcdd5446891
+SIZE (zlib-0.5.0.0.tar.gz) = 122533
diff --git a/archivers/hs-zlib/pkg-descr b/archivers/hs-zlib/pkg-descr
new file mode 100644
index 000000000000..8d178293cde6
--- /dev/null
+++ b/archivers/hs-zlib/pkg-descr
@@ -0,0 +1,8 @@
+This package provides a pure interface for compressing and decompressing
+streams of data represented as lazy ByteStrings. It uses the zlib C
+library so it has high performance. It supports the "zlib", "gzip" and
+"raw" compression formats. It provides a convenient high level api suitable
+for most tasks and for the few cases where more control is needed it provides
+access to the full zlib feature set.
+
+WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/zlib
diff --git a/archivers/hs-zlib/pkg-plist b/archivers/hs-zlib/pkg-plist
new file mode 100644
index 000000000000..34e27c2458d2
--- /dev/null
+++ b/archivers/hs-zlib/pkg-plist
@@ -0,0 +1,18 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSzlib-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSzlib-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Compression/GZip.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Compression/Zlib.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Compression/Zlib/Internal.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Compression/Zlib/Raw.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Compression/Zlib/Stream.hi
+%%SUBDIR%%/register.sh
+share/doc/zlib-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/zlib-%%PORTVERSION%%
+@dirrm lib/zlib-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec/Compression/Zlib
+@dirrm lib/zlib-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec/Compression
+@dirrm lib/zlib-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec
+@dirrm lib/zlib-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/zlib-%%PORTVERSION%%
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister zlib
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old