aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
commit5fb9edd6bda35148388cbd149c7fa48f4749f514 (patch)
treefd3fa9b642407455ac306d9a4732b8ea68fd8c43 /archivers/rpm4
parent3ca9aed4201adba81415517e7e132bd8f99b03f7 (diff)
downloadports-5fb9edd6bda35148388cbd149c7fa48f4749f514.tar.gz
ports-5fb9edd6bda35148388cbd149c7fa48f4749f514.zip
Multiple ports: improve regex compliance
These changes largely fall into just two categories: 1. Need textproc/gsed for GNU extensions 2. Extraneous escapes that can go away For #1, there's a further subdivision into those that require autoconf magic and those that can get away with BINARY_ALIAS=sed=${LOCALBASE}/bin/gsed. -CURRENT will soon gain GNU extensions, but these will take longer to get to all supported releases; we must switch them to gsed to ensure we're actually properly building them as intended. For #2, I've fixed these as I can and we should upstream these fixes. PORTREVISION is bumped for all of the above, because we will almost certainly build these differently when the replacements actually start working. These were all detected by the below-referenced exp-run [1]. The patch included forbids many ordinary characters from being escaped, since we'll later imbue those with special meanings. This has had the nice side effect of picking up various things that we didn't handle properly, e.g. \t and \r for tab and carriage return. PR: 229925 [1] Approved by: koobs (mentor) Approved by: portmgr (blanket: trivial build fixes) MFH: no (invasive risk) Differential Revision: https://reviews.freebsd.org/D25185
Notes
Notes: svn path=/head/; revision=538197
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 356359505bab..7e79f3dcc08a 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.15.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://ftp.rpm.org/releases/rpm-4.15.x/
PKGNAMESUFFIX= 4
@@ -14,6 +14,7 @@ COMMENT= Red Hat Package Manager
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libpopt.so:devel/popt \
libnss3.so:security/nss \
libzstd.so:archivers/zstd
@@ -25,6 +26,7 @@ USES= alias bdb compiler:openmp gmake iconv libarchive libtool \
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
SHEBANG_FILES= scripts/brp-python-bytecompile scripts/check-prereqs \
scripts/check-rpaths-worker scripts/pythondeps.sh \
scripts/pkgconfigdeps.sh scripts/fontconfig.prov \