aboutsummaryrefslogtreecommitdiff
path: root/audio/flac
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-09-24 18:04:34 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-09-24 18:04:34 +0000
commit39babfd9324e626a0a5e6e664f0b090ee3c4315e (patch)
tree4f46f8905e2cb2f0eb38cd23c625a3555e19b748 /audio/flac
parenta70f6336598ff3eb01073ec79cae942cf2bdb91f (diff)
downloadports-39babfd9324e626a0a5e6e664f0b090ee3c4315e.tar.gz
ports-39babfd9324e626a0a5e6e664f0b090ee3c4315e.zip
Convert to stage, use options helpers, make full use of stage for
optionally packaging the docs.
Notes
Notes: svn path=/head/; revision=328184
Diffstat (limited to 'audio/flac')
-rw-r--r--audio/flac/Makefile27
-rw-r--r--audio/flac/files/patch-Makefile.in14
-rw-r--r--audio/flac/pkg-plist2
3 files changed, 9 insertions, 34 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index ca235de0b215..8a16a4325046 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -10,11 +10,11 @@ MASTER_SITES= http://downloads.xiph.org/releases/flac/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
-LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
USES= pathfix pkgconfig
-NO_STAGE= yes
USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sse \
@@ -26,24 +26,11 @@ CONFIGURE_ARGS= --enable-sse \
OPTIONS_DEFINE= DOCS ICONV
OPTIONS_DEFAULT=ICONV
-.include <bsd.port.options.mk>
+ICONV_USES= iconv
+ICONV_CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include
+ICONV_LDFLAGS= -L${LOCALBASE}/lib
-.if ${PORT_OPTIONS:MICONV}
-USES+= iconv
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-MAKE_ENV+= DOC=doc
-.else
-MAKE_ENV+= DOC=""
-.endif
-
-USE_LDCONFIG= yes
-MAN1= flac.1 metaflac.1
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
@@ -59,4 +46,4 @@ post-build:
regression-test: build
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/flac/files/patch-Makefile.in b/audio/flac/files/patch-Makefile.in
deleted file mode 100644
index 7246f1072586..000000000000
--- a/audio/flac/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig 2013-05-27 10:11:58.639908000 +0200
-+++ Makefile.in 2013-06-09 18:13:05.000000000 +0200
-@@ -323,7 +323,7 @@ top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- ACLOCAL_AMFLAGS = -I m4
--SUBDIRS = doc include m4 man src examples test build objs
-+SUBDIRS = $(DOC) include m4 man src examples test build objs
- EXTRA_DIST = \
- COPYING.FDL \
- COPYING.GPL \
diff --git a/audio/flac/pkg-plist b/audio/flac/pkg-plist
index 87a1fba987d9..9f7bf39c84f8 100644
--- a/audio/flac/pkg-plist
+++ b/audio/flac/pkg-plist
@@ -25,6 +25,8 @@ lib/libFLAC.so
lib/libFLAC.so.11
libdata/pkgconfig/flac++.pc
libdata/pkgconfig/flac.pc
+man/man1/flac.1.gz
+man/man1/metaflac.1.gz
share/aclocal/libFLAC++.m4
share/aclocal/libFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/FLAC.tag