aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-shout
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:05:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:05:44 +0000
commit8cd3a9c929972c792945a33060be5091c9a5a41c (patch)
tree8a680f5e37f3bd674a32de17335835386c59a135 /audio/gmpc-shout
parentec6afdfcbadb3ad9541c4a06e649a0d20513e1db (diff)
downloadports-8cd3a9c929972c792945a33060be5091c9a5a41c.tar.gz
ports-8cd3a9c929972c792945a33060be5091c9a5a41c.zip
This plugin allows gmpc to play Shoutcast streams.
Notes
Notes: svn path=/head/; revision=210131
Diffstat (limited to 'audio/gmpc-shout')
-rw-r--r--audio/gmpc-shout/Makefile26
-rw-r--r--audio/gmpc-shout/distinfo3
-rw-r--r--audio/gmpc-shout/pkg-descr3
-rw-r--r--audio/gmpc-shout/pkg-plist4
4 files changed, 36 insertions, 0 deletions
diff --git a/audio/gmpc-shout/Makefile b/audio/gmpc-shout/Makefile
new file mode 100644
index 000000000000..7037dd8f2af2
--- /dev/null
+++ b/audio/gmpc-shout/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmpc-shout
+# Date created: March 27 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-shout
+PORTVERSION= 0.15.5.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION:C/\.0$//}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Shoutcast stream for gmpc
+
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XORG= x11
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-shout/distinfo b/audio/gmpc-shout/distinfo
new file mode 100644
index 000000000000..d09e1fc404e3
--- /dev/null
+++ b/audio/gmpc-shout/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-shout-0.15.5.0.tar.gz) = b120b136c44df877fe3de708c71e79d4
+SHA256 (gmpc-shout-0.15.5.0.tar.gz) = 398ae4e9f34ab31db374e66f0474f0e21775c3cb487230192b633cbea148c5dd
+SIZE (gmpc-shout-0.15.5.0.tar.gz) = 304681
diff --git a/audio/gmpc-shout/pkg-descr b/audio/gmpc-shout/pkg-descr
new file mode 100644
index 000000000000..8a11d020db73
--- /dev/null
+++ b/audio/gmpc-shout/pkg-descr
@@ -0,0 +1,3 @@
+This plugin allows gmpc to play Shoutcast streams.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-shout/pkg-plist b/audio/gmpc-shout/pkg-plist
new file mode 100644
index 000000000000..62b4deb1544e
--- /dev/null
+++ b/audio/gmpc-shout/pkg-plist
@@ -0,0 +1,4 @@
+share/gmpc/plugins/shoutplugin.la
+share/gmpc/plugins/shoutplugin.so
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc