aboutsummaryrefslogtreecommitdiff
path: root/audio/tagtool/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-11 17:57:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-11 17:57:46 +0000
commitc0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86 (patch)
tree605a39eae9f2bcb0b8684d4d3743292788b38bba /audio/tagtool/Makefile
parente2302ad137692aadbd7fc67047a9a779893f5b1d (diff)
downloadports-c0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86.tar.gz
ports-c0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86.zip
Notes
Diffstat (limited to 'audio/tagtool/Makefile')
-rw-r--r--audio/tagtool/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/tagtool/Makefile b/audio/tagtool/Makefile
new file mode 100644
index 000000000000..e8a70a5bdb8a
--- /dev/null
+++ b/audio/tagtool/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tagtool
+# Date created: 1st November 2004
+# Whom: Anthony Ginepro <anthony.ginepro@laposte.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagtool
+PORTVERSION= 0.11.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GNOME application that tag mp3/ogg files
+
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_GNOME= libglade2
+
+DATADIR= share/tagtool
+
+.include <bsd.port.mk>