aboutsummaryrefslogtreecommitdiff
path: root/biology/star/Makefile
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-01-11 17:39:52 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-01-11 17:39:52 +0000
commitd139fe0bb654de274a2f45f702d907dd7a4fa404 (patch)
tree7904424341dc41477a75643a6f9cc2ce31abfa4f /biology/star/Makefile
parentbced63b1b352dff0bdfaab9926ceb2d942396587 (diff)
downloadports-d139fe0bb654de274a2f45f702d907dd7a4fa404.tar.gz
ports-d139fe0bb654de274a2f45f702d907dd7a4fa404.zip
Notes
Diffstat (limited to 'biology/star/Makefile')
-rw-r--r--biology/star/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/biology/star/Makefile b/biology/star/Makefile
index accd60435794..29d08668449e 100644
--- a/biology/star/Makefile
+++ b/biology/star/Makefile
@@ -2,6 +2,7 @@
PORTNAME= STAR
DISTVERSION= 2.7.3a
+PORTREVISION= 1
CATEGORIES= biology
PKGNAMEPREFIX= rna-
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKDIR}/STAR-${DISTVERSION}/LICENSE
# 64-bit only, needs 16+ GiB RAM for typical eukaryotic genome
NOT_FOR_ARCHS= i386 powerpc
-USES= compiler:openmp gmake
+USES= compiler:c++11-lang gmake
USE_GITHUB= yes
GH_ACCOUNT= alexdobin
@@ -22,14 +23,7 @@ WRKSRC_SUBDIR= source
PLIST_FILES= bin/STAR
-.include <bsd.port.pre.mk>
-
-# Force newer compiler on platforms using GCC 4.2 as base
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
-USE_GCC= yes
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/STAR ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>