aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-01-11 16:51:15 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-01-11 16:51:15 +0000
commit1348c56403a5830af00d77709c4ed25568b57fdc (patch)
treed05c94f2618a1a242ead28306b3f2f818b52d5d5 /biology
parent43335a1b9c8369d8630083c7a406666cd40b550b (diff)
downloadports-1348c56403a5830af00d77709c4ed25568b57fdc.tar.gz
ports-1348c56403a5830af00d77709c4ed25568b57fdc.zip
biology/canu: Drop dependency on gcc
Replace compiler:openmp with compiler:c++11-lang and localbase PR: port/247753, ports/252379
Notes
Notes: svn path=/head/; revision=561227
Diffstat (limited to 'biology')
-rw-r--r--biology/canu/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/biology/canu/Makefile b/biology/canu/Makefile
index aa5969dbecbc..ac67d2b38b37 100644
--- a/biology/canu/Makefile
+++ b/biology/canu/Makefile
@@ -2,6 +2,7 @@
PORTNAME= canu
DISTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= biology java perl5
# Github auto-generated tarballs lack submodules
MASTER_SITES= https://github.com/marbl/canu/releases/download/v2.1/
@@ -19,7 +20,7 @@ NOT_FOR_ARCHS_REASON= __int128 is not supported on this target
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= gnuplot:math/gnuplot
-USES= compiler:openmp gmake perl5
+USES= compiler:c++11-lang gmake localbase perl5
USE_JAVA= yes
JAVA_RUN= yes
@@ -30,13 +31,6 @@ WRKSRC_SUBDIR= src
# using a separate install target.
MAKE_ENV= DESTDIR=${WRKSRC} CANU_BUILD_ENV=ports
-.include <bsd.port.pre.mk>
-
-# GCC 4.2.1 (still base compiler on some 2nd tier platforms) cannot build canu
-.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
-USE_GCC= yes
-.endif
-
pre-configure:
@${REINPLACE_CMD} \
-e 's|-O4||g' \
@@ -62,4 +56,4 @@ do-install:
(cd ${WRKSRC}/build && \
${COPYTREE_SHARE} "lib share" ${STAGEDIR}${PREFIX})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>