aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-04-21 07:44:44 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-04-21 07:44:44 +0000
commit256e9bc3b5b97069231e16e2be057e313e9bb7bc (patch)
treea8afb3578c105cb997a2c3e716ba287bcfb0b256 /biology
parente8c9857f5d7d32b517418fb317e827718430442b (diff)
downloadports-256e9bc3b5b97069231e16e2be057e313e9bb7bc.tar.gz
ports-256e9bc3b5b97069231e16e2be057e313e9bb7bc.zip
biology/py-crossmap: Fix build with Python 3.8+
* Add missing dependency devel/py-nose that is required to build. With Python 3.6/3.7 there are no build issues because the sdist contains Python Eggs of "nose" for these versions. While I'm here: * Set NO_ARCH because the port has no architecture specific files. * Make it concurrent safe, package installs a script and bump PORTREVISION due package change. PR: 253815 Approved by: portmgr (build fix) MFH: No (The port was added after the 2021Q1 branch)
Diffstat (limited to 'biology')
-rw-r--r--biology/py-crossmap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/biology/py-crossmap/Makefile b/biology/py-crossmap/Makefile
index 7946de949b5e..30b8bee8f5af 100644
--- a/biology/py-crossmap/Makefile
+++ b/biology/py-crossmap/Makefile
@@ -1,5 +1,6 @@
PORTNAME= crossmap
DISTVERSION= 0.5.2
+PORTREVISION= 1
CATEGORIES= biology python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +12,14 @@ COMMENT= Lift over genomics coordinates between assemblies
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0.10.4:devel/py-nose@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysam>0:biology/py-pysam@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bx-python>0:biology/py-bx-python@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyBigWig>0:biology/py-bigwig@${PY_FLAVOR}
USES= python:3.5+
-USE_PYTHON= autoplist cython distutils
+USE_PYTHON= autoplist concurrent cython distutils
+
+NO_ARCH= yes
.include <bsd.port.mk>